Opened 8 years ago

Closed 8 years ago

#27830 closed defect (fixed)

tomcat-native: Cannot find jni_md.h in /System/Library/Frameworks/JavaVM.framework/Home/

Reported by: ptm@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ts@…
Port: tomcat-native

Description

Mac OS X Version 10.6.5

Looks like my out of the box JavaVM.framework folder hierarchy does not match what is expected.

Full log is attached.

Attachments (1)

main.log (10.7 KB) - added by ptm@… 8 years ago.
Log of failed install

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by ptm@…

Attachment: main.log added

Log of failed install

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Keywords: jni_md.h removed

Could be the same problem as #26939 et al. Have you installed Java for Mac OS X 10.6 Update 3 but not Java for Mac OS X 10.6 Update 3 Developer Package?

comment:2 Changed 8 years ago by ptm@…

I believe something similar is going on as I had to play with a few softlinks to get jvcs to build. I have not installed any java packages, but everything seems to be there, just not where macports seems to expect it to be :-(

For example, jni_md.h is located at: /System/Library/Frameworks/JavaVM.framework/Headers

It is a link: jni_md.h@ -> ../../CurrentJDK/Headers/jni_md.h

I'm new to Mac, but not Unix. All I can note is that macports is looking for this file in (from the log):

:info:configure   adding "-I/System/Library/Frameworks/JavaVM.framework/Home/include" to TCNATIVE_PRIV_INCLUDES
:info:configure checking os_type directory... Cannot find jni_md.h in /System/Library/Frameworks/JavaVM.framework/Home/

...and it is not there...

I'm not sure what the next line in the log is suggesting...

:info:configure configure: error: You should retry --with-os-type=SUBDIR

comment:3 Changed 8 years ago by jmroot (Joshua Root)

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Summary: sudo port install tomcat-native fails - Error cannot find jni_md.htomcat-native: Cannot find jni_md.h in /System/Library/Frameworks/JavaVM.framework/Home/

comment:5 in reply to:  3 Changed 8 years ago by ptm@…

I've now installed the package as requested. Many thanks for pointing me at the developer centre. However, on inspecting the JavaVM.framework folder I find everything is still where is was... albeit some files with today's date.

Any way, I pressed ahead a tried again to run - sudo port install tomcat-native - with the same result. Have Apple move things around for this version of Snow Leopard?

comment:6 Changed 8 years ago by ptm@…

In order to get past this issue I adding the following softlink in /Library/Java/Home

include@ -> ../Headers

That did the trick, but why was this necessary?

Thanks for all your help

Cheers

Paul

comment:7 Changed 8 years ago by ts@…

Cc: ts@… added

Cc Me!

comment:8 Changed 8 years ago by mmpestorich (Mike M Pestorich)

Ran into this same problem when trying to install on Lion. I found this link that helped: building-universal-apache-tomcat-native-library-on-osx. Look toward the bottom of the page under the section entitled "A Note About Lion". It seems some header files have moved as indicated previously in this thread. I was able to successfully build and install by modifying one of the port definition's configure options to be --with-java-home=/System/Library/Frameworks/JavaVM.framework/Versions/A/.

comment:9 Changed 8 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.