Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#27899 closed defect (fixed)

kdeedu4 @4.5.4 build fails, problem related to GNU R

Reported by: juergen@… Owned by: nerdling (Jeremy L)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: nerdling (Jeremy L), sharky@…
Port: kdeedu4

Description

I notice that the kdeedu4 package fails to build for me with the following message:

$ port install kdeedu4
--->  Computing dependencies for kdeedu4
--->  Fetching kdeedu4
--->  Verifying checksum(s) for kdeedu4
--->  Extracting kdeedu4
--->  Applying patches to kdeedu4
--->  Configuring kdeedu4
--->  Building kdeedu4
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for kdeedu4 is at: [...]
Error: Status 1 encountered during processing.

The log is attached to this ticket. I suppose that the line

:info:build CMake Error: Parse error in cache file
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdeedu4/
work/build/CMakeCache.txt.
Offending entry: ][/Library/Frameworks/R.framework][v]

from the log relates to the source of the problem. I have GNU R already installed (as the native Mac binary, see http://cran.case.edu/bin/macosx/), and during the building of kdeedu4, a R window opens without further info about what it's needed for. However, I do not really understand the cause of the problem, and would appreciate all help on diagnosing this further.

My system is Snow Leopard, 10.6.6, with XCode 3.2.5.

Attachments (1)

main.log.bz2 (10.8 KB) - added by juergen@… 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by juergen@…

Attachment: main.log.bz2 added

comment:1 Changed 9 years ago by nerdling (Jeremy L)

Owner: changed from macports-tickets@… to snc@…
Status: newassigned

Thanks, I'll shut off checking for R.

comment:2 Changed 9 years ago by nerdling (Jeremy L)

Resolution: fixed
Status: assignedclosed

Disabled in r74942.

comment:3 Changed 9 years ago by jmroot (Joshua Root)

Port: kdeedu4 added
Note: See TracTickets for help on using tickets.