Opened 9 years ago

Closed 6 years ago

#27936 closed defect (fixed)

sunwait @20041208 does not accept eastern longitude

Reported by: nonstop.server@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: kurthindenburg (Kurt Hindenburg)
Port: sunwait

Description

When submitting an eastern longitude sunwait displays a warning and falls back to the default, using 77.069450W as longitude coordinate.

% sunwait -d12 -m1 -p 33.56S 18.25E
warning: latitude or longitude not set
	default coords of Alexandria, Virgina, USA used
Using location:             33.560000S, 77.069450W
Date:                       12 Jan 2011 
Local time:                 17:56 
Day length:                 14:12 hours
With civil twilight         15:06 hours
With nautical twilight      16:15 hours
With astronomical twilight  17:29 hours
Length of twilight:  civil   0:26 hours
                  nautical   1:01 hours
              astronomical   1:38 hours
Current specified time zone: CET (1 from UTC) 
Sun transits 1816 CET
                   Sun rises 1111 CET, sets 0121 CET
       Civil twilight starts 1043 CET, ends 0150 CET
    Nautical twilight starts 1009 CET, ends 0224 CET
Astronomical twilight starts 0932 CET, ends 0301 CET

Attachments (1)

sunwait-main.c.diff (451 bytes) - added by nonstop.server@… 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: sysutils removed

What makes you think this is not a problem upstream?

comment:2 in reply to:  1 Changed 9 years ago by nonstop.server@…

Replying to macsforever2000@…:

What makes you think this is not a problem upstream?

You're right, I should post this bug upstream. Sorry for the inconvenience.

comment:3 Changed 9 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

comment:4 Changed 9 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: closedreopened

More of a wontfix than invalid really (maybe we should add something like "third party to resolve").

comment:5 Changed 9 years ago by jmroot (Joshua Root)

Resolution: wontfix
Status: reopenedclosed

comment:6 Changed 8 years ago by nonstop.server@…

After reporting this issue upstream the developer was unable to reproduce my problem, so there was not much he could do.
I have made one small change in the code of main.c that solved my problem and would like to share it with anyone who encounters this issue.
The developer has been informed, but I never got an reply on my question if this change was acceptable or not.
See the attached patch sunwait-main.c.diff for the change.

Changed 8 years ago by nonstop.server@…

Attachment: sunwait-main.c.diff added

comment:7 Changed 8 years ago by mf2k (Frank Schima)

Resolution: wontfix
Status: closedreopened

comment:8 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Cc: khindenburg@… added

Cc Me!

comment:9 Changed 6 years ago by kurthindenburg (Kurt Hindenburg)

Resolution: fixed
Status: reopenedclosed

I went ahead and used your patch - thanks - r124149

Note: See TracTickets for help on using tickets.