Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#28000 closed update (fixed)

update poppler to 0.16.0

Reported by: florian@… Owned by: dbevans (David B. Evans)
Priority: Low Milestone:
Component: ports Version:
Keywords: haspatch Cc: rmstonecipher@…
Port: poppler

Description

See attached patch. I hope this does not break any packages depending on a specific poppler version.

Attachments (2)

Portfile.diff (1.1 KB) - added by florian@… 10 years ago.
library_checker.sh (241 bytes) - added by rmstonecipher@… 10 years ago.
script to test for libpoppler.7.dylib

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by florian@…

Attachment: Portfile.diff added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…

Library versions have changed so dependents will need rev bumping.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: rmstonecipher@… added

Ryan, did you test that dependents still work after r75618?

comment:3 Changed 10 years ago by rmstonecipher@…

Josh,
In r75626 I increased the revision of ports listed by 'port echo depends:poppler' as well as ports installed on my computer which include links to libpoppler.7.dylib.
If additional bugs are caused by links to libpoppler.7.dylib let me know.

Cheers,
Ryan

P.S. If indirect dependents are known to link to libraries which they do not directly depend upon, might it be helpful to explicitly include those libraries in depends_lib (or depends_lib-append) to reduce the need for otool-script-based investigation?

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

comment:5 Changed 10 years ago by jmroot (Joshua Root)

BTW I didn't think texlive-basic or texlive-latex installed any binaries?

comment:6 in reply to:  5 Changed 10 years ago by drkp (Dan Ports)

Replying to jmr@…:

BTW I didn't think texlive-basic or texlive-latex installed any binaries?

I came here to point out the same thing. They don't. Not that it's a big deal.

comment:7 Changed 10 years ago by rmstonecipher@…

Dan, Josh,
I did not mean for users to throw extra dinosaur chips in the furnace for naught.
I believe I edited the attached script (used on libpng12 to 14 transition) to correctly identify that those two ports provided files which linked to libpoppler.7.dylib.
Should I be using some additional test to avoid false positives?

Changed 10 years ago by rmstonecipher@…

Attachment: library_checker.sh added

script to test for libpoppler.7.dylib

comment:8 Changed 10 years ago by jmroot (Joshua Root)

You could check that the files are not in fact links, with e.g. test -L.

Note: See TracTickets for help on using tickets.