Opened 10 years ago

Closed 9 years ago

#28313 closed defect (duplicate)

gtk-doc bombs in configure

Reported by: turkowski Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: gtk-doc

Description (last modified by ryandesign (Ryan Schmidt))

White trying to install inkscape, gtk-doc bombed:

"Could not find DocBook XML DTD V4.3 in XML catalog."

Could there be a missing dependency?

I had a successful 1.13 and 1.14 install, but I removed them to try reinstalling, but now they fail as well.

--->  Configuring gtk-doc
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
----- Configure output follows -------
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /opt/local/bin/gmkdir -p
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... yes
checking whether ln -s works... yes
checking for pkg-config... /opt/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking gnome-doc-utils >= 0.3.2... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for library containing strerror... none required
checking for gcc... (cached) gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for gcc option to accept ISO C89... (cached) none needed
checking dependency style of gcc... (cached) gcc3
checking build system type... x86_64-apple-darwin10.6.0
checking host system type... x86_64-apple-darwin10.6.0
checking for a sed that does not truncate output... /opt/local/bin/gsed
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for fgrep... /usr/bin/grep -F
checking for ld used by gcc... /usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld) is GNU ld... no
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm
checking the name lister (/usr/bin/nm) interface... BSD nm
checking the maximum length of command line arguments... 196608
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking for /usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld option to reload object files... -r
checking for objdump... no
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm output from gcc object... ok
checking for dsymutil... dsymutil
checking for nmedit... nmedit
checking for lipo... lipo
checking for otool... otool
checking for otool64... no
checking for -single_module linker flag... yes
checking for -exported_symbols_list linker flag... yes
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fno-common -DPIC
checking if gcc PIC flag -fno-common -DPIC works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin10.6.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking for pkg-config... (cached) /opt/local/bin/pkg-config
checking pkg-config is at least version 0.19... yes
checking for perl... /usr/bin/perl
checking if Perl version >= 5.6.0... yes
checking for a Python interpreter with version >= 2.3... python
checking for python... /usr/bin/python
checking for python version... 2.6
checking for python platform... darwin
checking for python script directory... ${prefix}/lib/python2.6/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.6/site-packages
checking for openjade... no
checking for jade... no
configure: WARNING: Could not find openjade or jade, so SGML is not supported
checking for xsltproc... /usr/bin/xsltproc
checking for dblatex... no
checking for fop... /opt/local/bin/fop
checking for XML catalog (/etc/xml/catalog)... not found
checking for xmlcatalog... /usr/bin/xmlcatalog
checking for DocBook XML DTD V4.3 in XML catalog... not found
configure: error: could not find DocBook XML DTD V4.3 in XML catalog

Attachments (1)

gtk-doc.log (48.9 KB) - added by turkowski 10 years ago.
log file

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by turkowski

Attachment: gtk-doc.log added

log file

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to devans@…
Port: gtk-doc added

Using WikiFormatting would be a good idea.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Based on #28305 I think this is a duplicate of #26151 also.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: ryandesign@… added
Resolution: duplicate
Status: closedreopened

Nope, somehow a number of tools are being found in /usr/bin here when they should be found in ${prefix}/bin, as well as the XML catalog being looked for in /etc/xml/catalog.

comment:4 Changed 10 years ago by turkowski

Is there a way that I can get past this problem with some magic incantation? For example, maybe uninstalling some ports and reinstalling them, or [temporarily] changing the order of the directories in my PATH?

comment:5 Changed 9 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually the attached log does look like a dupe. I can only assume that the reporter did something strange like running configure manually to get the configure output in the description.

Note: See TracTickets for help on using tickets.