Opened 10 years ago

Closed 10 years ago

#28341 closed defect (wontfix)

py26-mpi4py tries to apply -arch flag to mpicc

Reported by: marshall.ward@… Owned by: adfernandes (Andrew Fernandes)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: py26-mpi4py

Description (last modified by ryandesign (Ryan Schmidt))

When I try to build py26-mpi4py on 10.6, I get the following error:

:info:build /opt/local/bin/mpicc -fno-strict-aliasing -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -arch x86_64 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -c _configtest.c -o _configtest.o
:info:build cc1: error: unrecognized command line option "-arch"

mpicc doesn't support the -arch flag on my build, I do not know if this is specific to 10.6 or is true in general. Is it possible to remove this flag, or necessary to change it?

Attachments (1)

main.log (27.2 KB) - added by marshall.ward@… 10 years ago.
macport log

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by marshall.ward@…

Attachment: main.log added

macport log

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to adfernandes@…
Port: py26-mpi4py added

comment:2 Changed 10 years ago by adfernandes (Andrew Fernandes)

Curious. What version of openmpi do you have installed? Can you post the output of port installed openmpi? Thanks.

comment:3 Changed 10 years ago by marshall.ward@…

I had openmpi installed (openmpi @1.5_0+gcc44) but I was using mpich2 (mpich2 @1.2.1p1_1+gcc44 (active) ). I believe the problem is because I am using MacPorts-built gcc compilers, which don't appear to support the -arch tag. If I switch to the XCode gcc42, then there aren't any problems.

The mpi4py package builds without any problem if I deactivate mpich2 and activate openmpi (using +openmpi).

comment:4 Changed 10 years ago by adfernandes (Andrew Fernandes)

Resolution: wontfix
Status: newclosed

Hmm, strange... I use openmpi with gcc45 and have no problems. This would appear to be an mpich2 problem then. I'm closing the ticket since mpich2 is marked with nomaintainer.

The problem would appear to be in mpich2's wrapper script for cc. I think that the openmpi folks put a lot of effort into getting the wrapper right, but a lot of older MPI wrappers get it wrong, hence the folk-wisdom that cc-wrappers are "evil".

Note: See TracTickets for help on using tickets.