Opened 10 years ago

Closed 10 years ago

#28347 closed defect (invalid)

emacs-app does not read/remember correctly .emacs

Reported by: MaurizioLoreti Owned by: cssdev
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: emacs-app

Description

I have an .emacs file whose first lines are:

(set-background-color "#F0FFFF") ; Azure (set-foreground-color "#000080") ; Navy blue (set-cursor-color "#FF0000") ; Red (set-mouse-color "#FF7256") ; Coral1

and indeed the first window opened by emacs.app executes these instructions and is displayed using these colours. BUT, if I select File -> New frame from the menu, or if I type C-x 5 2, the second frame is displayed with the default colours. However, other instructions found in my .emacs file, like the following one:

(global-set-key "\C-cg" 'goto-line)

work in the second frame too; the problem is maybe that emacs-app reads correctly my .emacs file, but fails to remember some instructions when opening a second frame. I am attaching my whole .emacs, but I don't think its content is relevant.

Attachments (1)

my.emacs (18.6 KB) - added by MaurizioLoreti 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by MaurizioLoreti

Attachment: my.emacs added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to css@…
Port: emacs-app added

Please remember to fill in the Port field and cc the maintainer.

comment:2 Changed 10 years ago by cssdev

Resolution: invalid
Status: newclosed

This is a configuration error, not a port bug. You need to set the colors for the default frames, not just the current one. Try the following in your .emacs instead:

(setq default-frame-alist '((background-color . "#F0FFFF")
  (foreground-color . "#000080")))

See:

Note: See TracTickets for help on using tickets.