Opened 10 years ago

Closed 10 years ago

#28386 closed defect (fixed)

qemu @0.13.0 fails to build on ppc 10.5.8

Reported by: mikiok36@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: raimue (Rainer Müller)
Port: qemu

Description

qemu @0.13.0 will not install on my PPC 10.5.8 iMac G5. I attached 'main.log'.

This failure occurs maybe because Apple's GCC 4.0.1 does not define _CALL_DARWIN. You should use __APPLE__ instead.

So

tcg/ppc/tcg-target.h: 68: #if defined _CALL_DARWIN

should be

tcg/ppc/tcg-target.h: 68: #if defined _CALL_DARWIN || defined __APPLE__

Attachments (1)

main.log (57.9 KB) - added by mikiok36@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by mikiok36@…

Attachment: main.log added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: raimue@… added
Port: @0.13.0 removed
Summary: qemu fails to build on ppc 10.5.8qemu @0.13.0 fails to build on ppc 10.5.8

comment:2 Changed 10 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Thanks for the report. Fixed in r75950.

Note: See TracTickets for help on using tickets.