Opened 10 years ago

Closed 9 years ago

#28421 closed defect (fixed)

xmedcon requires pkgconfig

Reported by: jost@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: xmedcon

Description (last modified by ryandesign (Ryan Schmidt))

Dear all,

I tried to install Xmedcon on a newly updated Mac OS Snow Leopard. I therefore first completely removed macports (2.5 in the macports guide) and then re-installed it before trying to install xmedcon. Dependencies installed fine:

The following ports are currently installed:
  gcc44 @4.4.5_0 (active)
  gmp @5.0.1_0 (active)
  gperf @3.0.4_0 (active)
  libiconv @1.13.1_0 (active)
  libpng @1.4.5_0 (active)
  mpfr @3.0.0-p8_0 (active)
  zlib @1.2.5_0 (active)

But when it comes to xmedcon I get an error message

Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Log for xmedcon is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xmedcon/main.log
Error: Status 1 encountered during processing.

(see also the last 20 lines of the log file below or the attached log-file).

Any help would be welcome (and, please, explain patiently: I am not very at ease with Linux, though not afraid of the command line ;-)

Thanks in advance, Christian.

ps: in fact, I only need medcon, but it seems to be unavailable nowadays without the GUI in xmedcon?

:info:configure checking for XMEDCON_GLIB... configure: error: The pkg-config script could not be found or is too old.  Make sure it
:info:configure is in your PATH or set the PKG_CONFIG environment variable to the full
:info:configure path to pkg-config.
:info:configure 
:info:configure Alternatively, you may set the environment variables XMEDCON_GLIB_CFLAGS
:info:configure and XMEDCON_GLIB_LIBS to avoid the need to call pkg-config.
:info:configure See the pkg-config man page for more details.
:info:configure 
:info:configure To get pkg-config, see <http://pkg-config.freedesktop.org/>.
:info:configure See `config.log' for more details.
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xmedcon/work/xmedcon-0.10.4" && ./configure --prefix=/opt/local --disable-gui --with-png-prefix=/opt/local " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
:debug:configure Backtrace: configure failure: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for xmedcon): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for xmedcon is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xmedcon/main.log

Attachments (1)

main.log (19.0 KB) - added by jost@… 10 years ago.
Log for xmedcon is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xmedcon/main.log

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by jost@…

Attachment: main.log added

Log for xmedcon is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xmedcon/main.log

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: jost@… removed
Description: modified (diff)
Keywords: pkg-config problem removed
Owner: changed from macports-tickets@… to jameskyle@…
Summary: xmedcon cannot be install due to pkg-config problemxmedcon requires pkgconfig

Please use WikiFormatting so your posts are legible.

As reporter, you do not need to Cc yourself. You should, however, Cc the port's maintainer so he sees your ticket.

Issue confirmed; xmedcon clearly needs a build dependency on pkgconfig. To work around this problem until the maintainer fixes that, "sudo port install pkgconfig".

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

It also links with glib2, so it needs a dependency on that as well. ("sudo port install glib2" to work around that for now.)

comment:3 in reply to:  2 Changed 10 years ago by jost@…

Replying to ryandesign@…:

It also links with glib2, so it needs a dependency on that as well. ("sudo port install glib2" to work around that for now.)

Thanks a lot for the fast help, the two lib's did the trick (and sorry for the formatting, I will try to do better next time).

Christian.

comment:4 Changed 10 years ago by jameskyle@…

Resolution: fixed
Status: newclosed

Added buid_dependency for pkgconfig and depends_lib for glib2. Also incremented the version to xmedcon-10.6.

The most current is 10.7, but it produces a duplicate symbol error.

Changes in r76449

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

Please rewrite the glib2 dependency so that glib2-devel could also satisfy it -- as is already done in the gtk2 variant (so I guess you'll want to remove that dependency from the gtk2 variant then).

Consider also what implications this glib2 dependency has on the gtk2 and gtk1 variants -- does the gtk1 variant still work? If so, does it end up using both glib2 and glib1?

comment:6 Changed 9 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.