Opened 10 years ago

Closed 10 years ago

#28540 closed defect (duplicate)

libplist wont compile with swig 2.0.2

Reported by: macports@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: swig

Description

Hello,

I started with a clean install, and "sudo port install digikam". Not counting minor glitches it went well till libplist. If modify the swig portfile to te one in the SVN at version 2.0.1 (last one) it works ok.

The problem seems to be the install path of "python.swg" and 2 more files, which are in a different install path in 2.0.1 and 2.0.2.

--->  Fetching swig
--->  Attempting to fetch swig-2.0.2.tar.gz from http://ovh.dl.sourceforge.net/swig
--->  Verifying checksum(s) for swig
--->  Extracting swig
--->  Configuring swig
--->  Building swig
--->  Staging swig into destroot
--->  Installing swig @2.0.2_0
--->  Activating swig @2.0.2_0
--->  Cleaning swig
--->  Fetching swig-python
--->  Attempting to fetch swig-2.0.1.tar.gz from http://lil.fr.distfiles.macports.org/swig
--->  Verifying checksum(s) for swig-python
--->  Extracting swig-python
--->  Configuring swig-python
--->  Building swig-python
--->  Staging swig-python into destroot
--->  Installing swig-python @2.0.1_0
--->  Activating swig-python @2.0.1_0
--->  Cleaning swig-python
--->  Fetching libplist
--->  Attempting to fetch libplist-1.3.tar.bz2 from http://lil.fr.distfiles.macports.org/libplist
--->  Verifying checksum(s) for libplist
--->  Extracting libplist
--->  Configuring libplist
--->  Building libplist
Error: Target org.macports.build returned: shell command failed
Log for libplist is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/main.log
:info:build [ 94%] Swig source
:info:build cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig && /opt/local/bin/swig -python -Werror -Wall -modern -outdir /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig -c++ -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/include -I/System/Library/Frameworks/Python.framework/Headers -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig/plistPYTHON_wrap.cxx /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig/plist.i
:info:build :3: Error: Unable to find 'python.swg'
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig/plist.i:9: Error: Unable to find 'std_string.i'
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libplist/work/libplist-1.3/swig/plist.i:114: Error: Unable to find 'std_map.i'
:info:build make[2]: *** [swig/plistPYTHON_wrap.cxx] Error 1
:info:build make[1]: *** [swig/CMakeFiles/_plist.dir/all] Error 2
:info:build make: *** [all] Error 2

Change History (1)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: swig libplist removed
Port: swig added
Resolution: duplicate
Status: newclosed

Duplicate of #28529.

Note: See TracTickets for help on using tickets.