Opened 10 years ago

Closed 10 years ago

#28593 closed defect (fixed)

autoconf needs rev bump for new perl version

Reported by: FredericVivien (Frédéric Vivien) Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: autoconf

Description (last modified by ryandesign (Ryan Schmidt))

An upgrade of outdated ports on my computer lead to an attempts to install coreutils 8.10 which failed because of:

:info:configure sh: /opt/local/bin/autoreconf: /opt/local/bin/perl: bad interpreter: No such file or directory

Perl was installed:

port installed perl5.12 perl5
The following ports are currently installed:
  perl5 @5.8.9_0
  perl5 @5.12.3_0+perl5_12
  perl5.12 @5.12.3_0 (active)

But there was no link /opt/local/bin/perl Installing p5-locale-gettext solved the problem.

Change History (5)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

The dependencies are fine. coreutils depends on autoconf depends on perl5 which provides /opt/local/bin/perl when it is activated, but it was not on your system. The solution was to activate it.

The upgrade to perl 5.12 has not been accomplished in a way that necessarily leaves things in working order after upgrading. This is currently being discussed on the mailing lists.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to ram@…
Port: autoconf added
Summary: coreutils is missing dependencies to p5-locale-gettextautoconf needs rev bump for new perl version

comment:3 Changed 10 years ago by jmroot (Joshua Root)

The dependency should also be port:perl5 BTW.

comment:4 Changed 10 years ago by skymoo (Adam Mercer)

Status: newassigned

comment:5 Changed 10 years ago by skymoo (Adam Mercer)

Resolution: fixed
Status: assignedclosed

rev bumped and dependency to port:perl5 added in r76630

Note: See TracTickets for help on using tickets.