Opened 10 years ago

Closed 10 years ago

#28616 closed defect (invalid)

py26-gtk needs revision bump because of libpng dependency

Reported by: lifechoose@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: libpng12 Cc:
Port: py26-gtk

Description

On Mac OS X 10.5.8:

sudo port install py26-gtkPassword:
--->  Computing dependencies for py26-gtk
--->  Building py26-gtk
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for py26-gtk is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py26-gtk/main.log

At the end of the above main.log:

:info:build grep: /opt/local/lib/libpng12.la: No such file or directory
:info:build /opt/local/bin/gsed: can't read /opt/local/lib/libpng12.la: No such file or directory
:info:build libtool: link: `/opt/local/lib/libpng12.la' is not a valid libtool archive
:info:build make[2]: *** [gtkunixprint.la] Error 1
:info:build make[1]: *** [all-recursive] Error 1

I've found the problem is due to #28029 (and others #28049,#28438,#28016) and solution is at r75159, without py26-gtk.

Running search-libpng12.sh gives the following from my mac - why does not include py26-gtk???

gd2
gegl
gnome-keyring
gnuplot
graphviz
gtk2
kcachegrind
libbonoboui
libgdiplus
libglade2
libgnomecanvas
libgnomeui
libgsf
libopenraw
librsvg
libwmf
openmotif
pango
poppler

BTW, how should I upgrade rev bump like r75241 or r75258? Do I just do selfupdate then upgrade the corresponding port?

Thanks!

Attachments (1)

search-libpng12.sh (235 bytes) - added by lifechoose@… 10 years ago.
seach-libpng12.sh

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by lifechoose@…

Attachment: search-libpng12.sh added

seach-libpng12.sh

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

It already got one. r75190. clean and try again.

comment:2 Changed 10 years ago by lifechoose@…

Resolution: invalid
Status: closedreopened

could be more specific on how to 'clean and try again'?

I've done sudo port selfupdate then, sudo port install py26-gtk

still the same.

sorry being stupid here but quite new to macports world and know little about how to apply Portfile patches here. In fact don't really understand 'rev bump' no information found on http://guide.macports.org/ either. Any link can be referred to? thanks.

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: reopenedclosed

Please do not re-open the ticket as the issue was already resolved. If you need tech support you should post to the Macports-Users mailing list. Trac is for bug reports and feature requests only.

You need to run the following:

sudo port clean py26-gtk
sudo port upgrade py26-gtk
Note: See TracTickets for help on using tickets.