Opened 9 years ago

Closed 9 years ago

#28819 closed defect (invalid)

linuxdoc-tools 0.9.66: destroot fails in UTF-8 locale (expand: stdin: Illegal byte sequence)

Reported by: mklein-de (Michael Klein) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: haspatch maintainer Cc: ryandesign (Ryan Schmidt)
Port: linuxdoc-tools

Description

expand(1) chokes on latin1 encoded input file.

Debug output and Portfile patch is attached

Attachments (2)

main.log (311.8 KB) - added by mklein-de (Michael Klein) 9 years ago.
debug output
Portfile.diff (371 bytes) - added by mklein-de (Michael Klein) 9 years ago.
Portfile patch

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by mklein-de (Michael Klein)

Attachment: main.log added

debug output

Changed 9 years ago by mklein-de (Michael Klein)

Attachment: Portfile.diff added

Portfile patch

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: maintainer added

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

How can I reproduce this failure? It installs fine for me.

comment:3 Changed 9 years ago by mklein-de (Michael Klein)

It seems I have added LC_CTYPE to extra_env $prefix/etc/macports.conf some time ago, if I could just remember why... Without this it builds here, too.

To reproduce, export LC_CTYPE="de_DE.UTF-8" (or some other UTF-8 locale) and add it to extra_env

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Since macports.conf says "setting extra_env is intended for advanced users and is unsupported" I'm inclined to close this ticket as invalid then. Or do you feel strongly that this patch should be applied?

comment:5 Changed 9 years ago by mklein-de (Michael Klein)

never mind, just close it.

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.