Opened 10 years ago

Closed 10 years ago

#29141 closed defect (fixed)

qt4-mac dependents on 10.7 - qglobal.h:93:6: error: #error "This version of Mac OS X is unsupported"

Reported by: sorin.sbarnea@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 1.9.99
Keywords: lion Cc: cssdev, nerdling (Jeremy Lavergne), jamesfmarshall@…, m.haller@…, axeljaeger@…, jdswinbank (John Swinbank), whcordis@…, mkae (Marko Käning), st.hennig@…, hofione@…, avysk (Alexey Vyskubov), cdeil (Christoph Deil), obutovich@…, muchatel@…, soehn@…, geekosaur
Port: qt4-mac doxygen

Description (last modified by ryandesign (Ryan Schmidt))

doxygen fails to install on 10.7, svn macports

qglobal.h:93:6: error: #error "This version of Mac OS X is unsupported"

Attachments (1)

main.log (19.3 MB) - added by soehn@… 10 years ago.

Change History (33)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Milestone: MacPorts 2.0.0
Owner: changed from macports-tickets@… to css@…
Priority: HighNormal

MacPorts on Mac OS X 10.7 is unsupported in general, until Mac OS X 10.7 is released by Apple to the general public and we've had a chance to play with it.

comment:2 Changed 10 years ago by sorin.sbarnea@…

I read that for 10.7 we are supposed to use trunk, which I did and worked pretty well because there are no major changes. And as developers we are supposed to use prerelease versions because this is the only way of preparing macports to be ready for normal users. But this is not the problem.

I found that the issue is trivial because original qt developer wrote some code with a silly enforced lifetime limitation.

It was enough to comment the line that throws the error to make doxygen to work!

Please comment line #96, it will solve the issue, or better replace it with an warning.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: css@… added
Owner: changed from css@… to michaelld@…
Port: qt4-mac added
Summary: doxygen on 10.7 - qglobal.h:93:6: error: #error "This version of Mac OS X is unsupported"qt4-mac dependents on 10.7 - qglobal.h:93:6: error: #error "This version of Mac OS X is unsupported"

So presumably this only happens with +wizard, and should actually be against qt4-mac.

comment:4 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added
Keywords: lion added

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

This patch build successfully on 10.6.

comment:6 Changed 10 years ago by jamesfmarshall@…

Cc: jamesfmarshall@… added

Cc Me!

comment:7 Changed 10 years ago by m.haller@…

/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/qt4-mac/work/qt-everywhere-opensource-src-4.7.3/src/corelib/global/qglobal.h (md5: 351810032e11221cff61def243eea975) of qt4-mac 4.7.3 has to be patched

319,322c319
< #  if !defined(MAC_OS_X_VERSION_10_7)
< #       define MAC_OS_X_VERSION_10_7 MAC_OS_X_VERSION_10_6 + 1
< #  endif
< #  if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_7)
---
> #  if (MAC_OS_X_VERSION_MAX_ALLOWED > MAC_OS_X_VERSION_10_6)

comment:8 Changed 10 years ago by michaelld (Michael Dickens)

I'm traveling right now, and probably won't be able to download / install Lion until early August. So, unless someone can come up with a patch in the interim, folks will just have to be patient for a few weeks until I can get to this ticket. I grant permission for others to checkin fixes for this ticket, if/as appropriate.

comment:9 Changed 10 years ago by m.haller@…

Cc: m.haller@… added

Cc Me!

comment:10 Changed 10 years ago by axeljaeger@…

Cc: axeljaeger@… added

Cc Me!

comment:11 in reply to:  7 Changed 10 years ago by nerdling (Jeremy Lavergne)

Replying to m.haller@…:

src/corelib/global/qglobal.h has to be patched

Have you come across any other files that need patched? I'm testing this one presently and will commit it after a successful build.

comment:12 Changed 10 years ago by craig+macports@…

Please see also ticket:30346 which is another required patch for qt4 on 10.7

comment:13 Changed 10 years ago by jdswinbank (John Swinbank)

Cc: swinbank@… added

Cc Me!

comment:14 Changed 10 years ago by whcordis@…

Cc: whcordis@… added

Cc Me!

comment:15 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: mk@… added

Duplicate: #30402

comment:16 Changed 10 years ago by st.hennig@…

Cc: st.hennig@… added

Cc Me!

comment:17 Changed 10 years ago by hofione@…

Cc: hofione@… added

Cc Me!

comment:18 Changed 10 years ago by avysk (Alexey Vyskubov)

Cc: tascafoo@… added

Cc Me!

comment:19 Changed 10 years ago by cdeil (Christoph Deil)

Cc: Deil.Christoph@… added

Cc Me!

comment:20 Changed 10 years ago by obutovich@…

Cc: obutovich@… added

Cc Me!

comment:21 Changed 10 years ago by muchatel@…

Cc: muchatel@… added

Cc Me!

comment:22 Changed 10 years ago by soehn@…

Cc: soehn@… added

Cc Me!

comment:23 Changed 10 years ago by obutovich@…

I have attached to ticket:30346 Portfile and patches, wich work for me... Hope it helps

comment:24 Changed 10 years ago by geekosaur

Cc: allbery.b@… added

Cc Me!

comment:25 Changed 10 years ago by michaelld (Michael Dickens)

Committed in r81844. Please do a selfupdate & see if the changes work.

Changed 10 years ago by soehn@…

Attachment: main.log added

comment:26 in reply to:  25 Changed 10 years ago by soehn@…

Replying to michaelld@…:

Committed in r81844. Please do a selfupdate & see if the changes work.

I tried and have attached the result.

comment:27 Changed 10 years ago by michaelld (Michael Dickens)

Hmm ... looks like the patch to qglobal.h isn't working for 10.7 (it does for 10.6). I'll be installing 10.7 over this weekend & will figure out the issue then.

comment:28 Changed 10 years ago by michaelld (Michael Dickens)

Did you do a "clean" before trying to "install qt4-mac"? Sometimes back makes a difference. Another user on 10.7 reports success building using these latest changes.

comment:29 in reply to:  28 Changed 10 years ago by soehn@…

Replying to michaelld@…:

Did you do a "clean" before trying to "install qt4-mac"? Sometimes back makes a difference. Another user on 10.7 reports success building using these latest changes.

Before I try to install a port, that could not be build before, I always clean that port, run self update and upgrade outdated. I gave this another try today (the whole procedure as described above). It worked this time. (?) Thank you!

comment:30 Changed 10 years ago by michaelld (Michael Dickens)

I'm glad you take those steps for installing a broken port -- not everyone does. I does happen sometimes, that things break & then work; I'm glad it's working for you now.

Before closing this ticket: I'll wait to either hear back from someone else that it works for them; or, that it works for me on my almost done 10.7 install (I'm testing on 10.6 still, but the code looks solid).

comment:31 in reply to:  30 Changed 10 years ago by jdswinbank (John Swinbank)

Replying to michaelld@…:

Before closing this ticket: I'll wait to either hear back from someone else that it works for them

Now builds for me on 10.7. Many thanks!

comment:32 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

Thanks for the replies. I'll close out the ticket since I think this issue is now fixed.

Note: See TracTickets for help on using tickets.