Opened 8 years ago

Closed 8 years ago

#29283 closed defect (invalid)

gcc46 4.6-20110325_0 -> 4.6-20110325_1 upgrade fails

Reported by: anatol (Anatol Pomozov) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: raimue (Rainer Müller)
Port: gcc46

Description (last modified by mf2k (Frank Schima))

The following installed ports are outdated:
gcc46                          4.6-20110325_0 < 4.6-20110325_1   

>  upgrade outdated
--->  Computing dependencies for gcc46
--->  Building gcc46
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for gcc46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc46/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

Here is the log file http://pastie.org/1836053

I checked the last commit from Raimue and do not see how it can break gcc46. The only thing I did recently is I upgraded my macosx from 10.6.4 to 10.6.7 and installed latest XCode (4.0.2).

Change History (4)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Cc: mww@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to mww@…

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

The log you've shown us shows an unclean build attempt. It could mean you tried to install gcc46, it failed (or you interrupted it), then upgraded Xcode, then tried to continue building gcc46. Please clean gcc46 and try again, and if it fails again, attach the complete main.log file to this ticket so we can get a clearer idea what happened.

comment:3 Changed 8 years ago by anatol (Anatol Pomozov)

Indeed it helped. Thanks for your help and sorry for the false alarm. Please close the ticket.

comment:4 Changed 8 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.