Opened 8 years ago

Closed 8 years ago

#29469 closed defect (invalid)

atlas: doesn't compile on MacBook Pro i7

Reported by: hansimglueck@… Owned by: jameskyle@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: atlas, macbook, i7, numpy, wxpython, matplotlib, compile Cc:
Port: atlas

Description (last modified by ryandesign (Ryan Schmidt))

Ticket #24869 has already treated this topic, but actually it did not work yet on my machine
My current tried approach:

  1. sudo port install py26-wxpython py26-numpy py26-matplotlib

--> atlas does not compile

  1. sudo port clean --all atlas
  2. sudo port install atlas +gcc45

--> atlas does not compile

  1. sudo port clean --all atlas
  2. sudo port install atlas + gcc44

--> atlas does not compile

Can you help me? I do not know how to figure out what kind of bug it is! main.log file attached!!

Thanks so far!

Attachments (1)

main.log (72.0 KB) - added by hansimglueck@… 8 years ago.
main.log file with gcc45, break after a while…

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by hansimglueck@…

Attachment: main.log added

main.log file with gcc45, break after a while...

comment:1 Changed 8 years ago by hansimglueck@…

Cc: hansimglueck@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: hansimglueck@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to jameskyle@…
Port: atlas added
Summary: MacBook Pro i7 'ATLAS' don't compileatlas: doesn't compile on MacBook Pro i7

As reporter, you do not need to Cc yourself. However, you should Cc the port's maintainer, and put the affected port's name in the Port field.

That main.log file doesn't look complete; It looks like it got truncated in the middle of a line. Please attach the complete file.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Priority: HighNormal

Also, the Priority should not generally be set to High.

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Probably a dupe of #28758.

comment:5 Changed 8 years ago by Veence (Vincent)

Please hold on until I have tried the new 3.9.41 version which should fix all reported bugs on OS X

comment:6 in reply to:  5 Changed 8 years ago by hansimglueck@…

Replying to vince@…:

Please hold on until I have tried the new 3.9.41 version which should fix all reported bugs on OS X

thanks so far, i will.

comment:7 Changed 8 years ago by hansimglueck@…

ok thanks guys sorry for waiting your time i tried it again and again... and now it works

I think my macbook hang up and break the installation....

The command:

sudo port clean --all atlas and sudo port install update

worked...

greets hans

comment:8 Changed 8 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.