Opened 8 years ago

Closed 8 years ago

#29493 closed defect (fixed)

gnupg mirror ftp.gnupg.org not available via HTTP

Reported by: nsowatsk@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: haspatch Cc:
Port: libgpg-error

Description

sudo port install libgpg-error 
--->  Computing dependencies for libgpg-error
--->  Verifying checksum(s) for libgpg-error
Error: Checksum (md5) mismatch for libgpg-error-1.10.tar.bz2
Error: Checksum (sha1) mismatch for libgpg-error-1.10.tar.bz2
Error: Checksum (rmd160) mismatch for libgpg-error-1.10.tar.bz2
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<http://trac.macports.org/wiki/MisbehavingServers>
***
Error: Target org.macports.checksum returned: Unable to verify file checksums
Log for libgpg-error is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libgpg-error/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

gnupg.org-no-http.patch (346 bytes) - added by neverpanic (Clemens Lang) 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by neverpanic (Clemens Lang)

Keywords: libgpg-error Checksum mismatch removed
Resolution: worksforme
Status: newclosed

Please delete ${PREFIX}/var/macports/distfiles/libgpg-error/libgpg-error-1.10.tar.bz2 and run sudo port -d checksum libgpg-error, reopen this bug and paste it's output if it fails again. Please also read MisbehavingServers and check the problem is not caused by one of the first three bullet points.

comment:2 Changed 8 years ago by neverpanic (Clemens Lang)

Instead of deleting the file manually, please use sudo port clean --dist libgpg-error. Sorry for the misinformation.

comment:3 in reply to:  2 Changed 8 years ago by nsowatsk@…

Resolution: worksforme
Status: closedreopened

Replying to cal@…:

Instead of deleting the file manually, please use sudo port clean --dist libgpg-error. Sorry for the misinformation.

Ah, should have read all my emails ...

I did the manual thing first, then saw the second comment :-(

sudo port clean --dist libgpg-error
Error: Unable to open port: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
To report a bug, see <http://guide.macports.org/#project.tickets>

Any ideas of how to sort this one out?

Thanks

Nathan

comment:4 Changed 8 years ago by neverpanic (Clemens Lang)

I doesn't matter, just ignore the error when cleaning and proceed to sudo port -d checksum libgpg-error.

comment:5 Changed 8 years ago by nsowatsk@…

OK, this is what I get:

sudo port -d checksum libgpg-errorPassword:
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error
DEBUG: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
    while executing
"cd $portpath"
    (procedure "mportopen" line 31)
    invoked from within
"mportopen $porturl [array get options] [array get requested_variations]"
Error: Unable to open port: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-mdr1-vl300-64-103-17-54:local nsowatsk$ sudo port clean --dist libgpg-errorError: Unable to open port: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-mdr1-vl300-64-103-17-54:local nsowatsk$ sudo port -d checksum libgpg-errorDEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error
DEBUG: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
    while executing
"cd $portpath"
    (procedure "mportopen" line 31)
    invoked from within
"mportopen $porturl [array get options] [array get requested_variations]"
Error: Unable to open port: couldn't change working directory to "/opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error": no such file or directory
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-mdr1-vl300-64-103-17-54:local nsowatsk$ 

comment:6 Changed 8 years ago by jmroot (Joshua Root)

Apparently you deleted the port directory and not just the distfile. Selfupdate to get it back.

comment:7 Changed 8 years ago by nsowatsk@…

sudo port -d checksum libgpg-errorDEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error
DEBUG: OS darwin/10.7.0 (Mac OS X 10.6) arch i386
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/archcheck-1.0.tcl
DEBUG: adding the default universal variant
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libgpg-error/work /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/libgpg-error/work
DEBUG: Starting logging for libgpg-error
DEBUG: Executing org.macports.main (libgpg-error)
--->  Fetching libgpg-error
DEBUG: fetch phase started at Wed May 18 14:52:13 CEST 2011
DEBUG: Executing org.macports.fetch (libgpg-error)
--->  libgpg-error-1.10.tar.bz2 doesn't seem to exist in /opt/local/var/macports/distfiles/libgpg-error
DEBUG: Pinging gd.tuwien.ac.at...
DEBUG: Pinging ftp.freenet.de...
DEBUG: Pinging ftp.jyu.fi...
DEBUG: Pinging www.ring.gr.jp...
DEBUG: Pinging ftp.gnupg.org...
DEBUG: Pinging distfiles.macports.org...
DEBUG: Pinging aarnet.au.distfiles.macports.org...
DEBUG: Pinging cjj.kr.distfiles.macports.org...
DEBUG: Pinging lil.fr.distfiles.macports.org...
DEBUG: Pinging sea.us.distfiles.macports.org...
DEBUG: Pinging ykf.ca.distfiles.macports.org...
DEBUG: gd.tuwien.ac.at ping time is 69.123
DEBUG: ftp.freenet.de ping time is 49.476
DEBUG: ftp.jyu.fi ping time is 82.630
DEBUG: www.ring.gr.jp ping time is 332.885
DEBUG: ftp.gnupg.org ping time is 46.066
DEBUG: distfiles.macports.org ping time is 195.020
DEBUG: aarnet.au.distfiles.macports.org ping time is 364.810
DEBUG: cjj.kr.distfiles.macports.org ping time is 10000
DEBUG: lil.fr.distfiles.macports.org ping time is 53.224
DEBUG: sea.us.distfiles.macports.org ping time is 10000
DEBUG: ykf.ca.distfiles.macports.org ping time is 139.698
--->  Attempting to fetch libgpg-error-1.10.tar.bz2 from http://ftp.gnupg.org/gcrypt/libgpg-error
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   151    0   151    0     0    774      0 --:--:-- --:--:-- --:--:--  2359
--->  Verifying checksum(s) for libgpg-error
DEBUG: checksum phase started at Wed May 18 14:52:16 CEST 2011
DEBUG: Executing org.macports.checksum (libgpg-error)
--->  Checksumming libgpg-error-1.10.tar.bz2
Error: Checksum (md5) mismatch for libgpg-error-1.10.tar.bz2
Portfile checksum: libgpg-error-1.10.tar.bz2 md5 736a03daa9dc5873047d4eb4a9c22a16
Distfile checksum: libgpg-error-1.10.tar.bz2 md5 22095249612f80b74ccb0820b902ec19
Error: Checksum (sha1) mismatch for libgpg-error-1.10.tar.bz2
Portfile checksum: libgpg-error-1.10.tar.bz2 sha1 95b324359627fbcb762487ab6091afbe59823b29
Distfile checksum: libgpg-error-1.10.tar.bz2 sha1 616b0cb40c9e17a7c4969da52b0956bb25af2c91
Error: Checksum (rmd160) mismatch for libgpg-error-1.10.tar.bz2
Portfile checksum: libgpg-error-1.10.tar.bz2 rmd160 435fcf1c748ae6877b5de7f133a741cd55dc1140
Distfile checksum: libgpg-error-1.10.tar.bz2 rmd160 348e6554664ec43ab4aa04b6b0e198a5643adc55
The correct checksum line may be:
checksums           md5     22095249612f80b74ccb0820b902ec19 \
                    sha1    616b0cb40c9e17a7c4969da52b0956bb25af2c91 \
                    rmd160  348e6554664ec43ab4aa04b6b0e198a5643adc55
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<http://trac.macports.org/wiki/MisbehavingServers>
***
Error: Target org.macports.checksum returned: Unable to verify file checksums
DEBUG: Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for libgpg-error): org.macports.checksum
Log for libgpg-error is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_libgpg-error/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
dhcp-mdr1-vl300-64-103-17-54:local nsowatsk$ 

Changed 8 years ago by neverpanic (Clemens Lang)

Attachment: gnupg.org-no-http.patch added

comment:8 Changed 8 years ago by neverpanic (Clemens Lang)

Keywords: haspatch added

The problem is caused by

  • you being behind a proxy that serves HTML instead of a proper error (with the corresponding error code) when it can't connect to http://ftp.gnupg.org/, which would cause macports to try the next mirror.
  • ftp.gnupg.org not being available via HTTP.

We should probably remove the corresponding entry from _resources/port1.0/fetch/mirror_sites.tcl. Patch attached.

comment:9 Changed 8 years ago by nsowatsk@…

Applied patch, problem fixed.

Many thanks! :-)

Nathan

comment:10 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: reopenedclosed
Summary: libgpg-error-1.10 Checksum (md5) mismatch forgnupg mirror ftp.gnupg.org not available via HTTP

Fixed in r78715.

Note: See TracTickets for help on using tickets.