Opened 8 years ago

Closed 6 years ago

#29546 closed defect (duplicate)

p5-tk: can't install x86_64 when tk +quartz installed

Reported by: marc@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: quartz Cc: mww@…
Port: p5-tk

Description (last modified by ryandesign (Ryan Schmidt))

# port install p5-tk
--->  Computing dependencies for p5-tk
Error: Cannot install p5-tk for the arch(s) 'x86_64' because
Error: its dependency tk only supports the arch(s) 'i386 ppc'.
Error: Unable to execute port: architecture mismatch

# port version 
Version: 1.9.2

# port list p5-tk tk
p5-tk                       @804.029     perl/p5-tk
tk                             @8.5.9          x11/tk

Change History (3)

comment:1 Changed 8 years ago by marc@…

Cc: marc@… added

Cc Me!

comment:2 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: mww@… added; marc@… removed
Description: modified (diff)
Keywords: quartz added; perl tk removed
Port: p5-tk added; tk removed
Summary: tk does not support arch x86_64p5-tk: can't install x86_64 when tk +quartz installed

This is only a problem if you request the +quartz variant of tk. See #20799. If you don't, tk has no problem building x86_64.

comment:3 Changed 6 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.