Opened 9 years ago

Closed 9 years ago

#30083 closed defect (worksforme)

boost fails ports install process due to syntax error in bootstrap.sh command

Reported by: stooee+macports@… Owned by: adfernandes (Andrew Fernandes)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: stooee+macports@…
Port: boost

Description (last modified by jmroot (Joshua Root))

text of full output from command:

smoosh:~ stooey$ sudo port install gimp
--->  Computing dependencies for gimp
--->  Dependencies to be installed: gimp-app gimp2 gegl libopenraw boost gimp-jp2 gimp-lqr-plugin liblqr gtk-nodoka-engine coreutils gutenprint icns-gimp ufraw cfitsio dcraw exiv2 gtkimageview lensfun xsane sane-backends
--->  Configuring boost
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Error: Failed to install boost
Log for boost is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/main.log
Error: The following dependencies were not installed: gimp-app gimp2 gegl libopenraw boost gimp-jp2 gimp-lqr-plugin liblqr gtk-nodoka-engine coreutils gutenprint icns-gimp ufraw cfitsio dcraw exiv2 gtkimageview lensfun xsane sane-backends
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (2)

main.log (2.5 KB) - added by stooee+macports@… 9 years ago.
main.2.log (11.0 KB) - added by stooee+macports@… 9 years ago.
new main.log from suggested command line

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to adfernandes@…

Please remember to preview and use WikiFormatting, and cc the maintainer. Please attach the log file mentioned in the output.

Changed 9 years ago by stooee+macports@…

Attachment: main.log added

comment:2 Changed 9 years ago by stooee+macports@…

Cc: stooee+macports@… added

Cc Me!

comment:3 Changed 9 years ago by adfernandes (Andrew Fernandes)

Can you sudo port -dv install boost by itself, not as a dependency of another port?

Changed 9 years ago by stooee+macports@…

Attachment: main.2.log added

new main.log from suggested command line

comment:4 Changed 9 years ago by stooee+macports@…

smoosh:~ stooey$ sudo port -dv install boost Password: DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/boost DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386 DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf DEBUG: universal variant already exists, so not adding the default one DEBUG: Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/boost/work DEBUG: Starting logging for boost DEBUG: epoch: in tree: 0 installed: 0 DEBUG: zlib 1.2.5_0 exists in the ports tree DEBUG: zlib 1.2.5_0 is the latest installed DEBUG: zlib 1.2.5_0 is active DEBUG: Merging existing variants into variants DEBUG: new fully merged portvariants: DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/archivers/zlib DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386 DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/xcodeversion-1.0.tcl DEBUG: adding the default universal variant DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf DEBUG: No need to upgrade! zlib 1.2.5_0 >= zlib 1.2.5_0 DEBUG: epoch: in tree: 0 installed: 0 DEBUG: expat 2.0.1_1 exists in the ports tree DEBUG: expat 2.0.1_1 is the latest installed DEBUG: expat 2.0.1_1 is active DEBUG: Merging existing variants into variants DEBUG: new fully merged portvariants: DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/expat DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386 DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: adding the default universal variant DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf DEBUG: No need to upgrade! expat 2.0.1_1 >= expat 2.0.1_1 DEBUG: epoch: in tree: 0 installed: 0 DEBUG: bzip2 1.0.6_0 exists in the ports tree DEBUG: bzip2 1.0.6_0 is the latest installed DEBUG: bzip2 1.0.6_0 is active DEBUG: Merging existing variants into variants DEBUG: new fully merged portvariants: DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/archivers/bzip2 DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386 DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf DEBUG: universal variant already exists, so not adding the default one DEBUG: No need to upgrade! bzip2 1.0.6_0 >= bzip2 1.0.6_0 DEBUG: epoch: in tree: 0 installed: 0 DEBUG: icu 4.6.1_0 exists in the ports tree DEBUG: icu 4.6.1_0 is the latest installed DEBUG: icu 4.6.1_0 is active DEBUG: Merging existing variants into variants DEBUG: new fully merged portvariants: DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/icu DEBUG: OS darwin/10.8.0 (Mac OS X 10.6) arch i386 DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.unload registered provides 'unload', a pre-existing procedure. Target override will not be provided DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided DEBUG: Using group file /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/group/muniversal-1.0.tcl DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/ports/_resources/port1.0/variant_descriptions.conf DEBUG: universal variant already exists, so not adding the default one DEBUG: No need to upgrade! icu 4.6.1_0 >= icu 4.6.1_0 ---> Computing dependencies for boost DEBUG: Searching for dependency: zlib DEBUG: Found Dependency: receipt exists for zlib DEBUG: Searching for dependency: expat DEBUG: Found Dependency: receipt exists for expat DEBUG: Searching for dependency: bzip2 DEBUG: Found Dependency: receipt exists for bzip2 DEBUG: Searching for dependency: icu DEBUG: Found Dependency: receipt exists for icu DEBUG: Executing org.macports.main (boost) ---> Fetching boost DEBUG: fetch phase started at Fri Jul 8 09:10:37 CDT 2011 DEBUG: Executing org.macports.fetch (boost) ---> Verifying checksum(s) for boost DEBUG: checksum phase started at Fri Jul 8 09:10:37 CDT 2011 DEBUG: Executing org.macports.checksum (boost) ---> Checksumming boost_1_46_1.tar.bz2 DEBUG: Correct (md5) checksum for boost_1_46_1.tar.bz2 DEBUG: Correct (sha1) checksum for boost_1_46_1.tar.bz2 DEBUG: Correct (rmd160) checksum for boost_1_46_1.tar.bz2 DEBUG: setting option extract.cmd to /usr/bin/bzip2 ---> Extracting boost DEBUG: extract phase started at Fri Jul 8 09:10:39 CDT 2011 DEBUG: Executing org.macports.extract (boost) ---> Extracting boost_1_46_1.tar.bz2 DEBUG: setting option extract.args to '/opt/local/var/macports/distfiles/boost/boost_1_46_1.tar.bz2' DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work" && /usr/bin/bzip2 -dc '/opt/local/var/macports/distfiles/boost/boost_1_46_1.tar.bz2' | /usr/bin/gnutar --no-same-owner -xf -' DEBUG: patch phase started at Fri Jul 8 09:11:43 CDT 2011 DEBUG: Executing org.macports.patch (boost) ---> Applying patches to boost ---> Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/boost/files/patch-tools_build_v2_engine_src_build.sh.diff DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_46_1" && /usr/bin/patch -p0' patching file tools/build/v2/engine/src/build.sh Hunk #1 succeeded at 133 with fuzz 1. ---> Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/boost/files/patch-tools_build_v2_engine_src_build.jam.diff DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_46_1" && /usr/bin/patch -p0' patching file tools/build/v2/engine/src/build.jam Hunk #1 succeeded at 202 (offset 8 lines). ---> Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/boost/files/patch-bootstrap.sh.diff DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_46_1" && /usr/bin/patch -p0' patching file bootstrap.sh DEBUG: Executing proc-post-org.macports.patch-patch-0 ---> Configuring boost DEBUG: Using compiler 'Mac OS X gcc 4.2' DEBUG: configure phase started at Fri Jul 8 09:11:43 CDT 2011 DEBUG: Executing org.macports.configure (boost) DEBUG: Environment: CPATH='/opt/local/include' CFLAGS='-pipe -O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.6' CXX='/usr/bin/g++-4.2' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' OBJC='/usr/bin/gcc-4.2' FCFLAGS='-pipe -O2 -m64' INSTALL='/usr/bin/install -c' OBJCFLAGS='-pipe -O2 -arch x86_64' FFLAGS='-pipe -O2 -m64' CC_PRINT_OPTIONS='YES' CC='/usr/bin/gcc-4.2' DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_46_1" && ./bootstrap.sh --prefix=/opt/local --without-libraries=python --without-libraries=mpi --with-icu=/opt/local' -n Building Boost.Jam with toolset darwin...

Failed to build Boost.Jam Consult 'bootstrap.log' for more details shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_46_1" && ./bootstrap.sh --prefix=/opt/local --without-libraries=python --without-libraries=mpi --with-icu=/opt/local " returned error 1 Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details) DEBUG: Backtrace: configure failure: shell command failed (see log for details)

while executing

"$procedure $targetname" Warning: the following items did not execute (for boost): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install Log for boost is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/main.log Error: Status 1 encountered during processing. To report a bug, see <http://guide.macports.org/#project.tickets>

comment:5 Changed 9 years ago by adfernandes (Andrew Fernandes)

Thanks.

In the above failure, the shell script leaves a log in /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/main.log. Can you please attach this log?

I just tried building and have no problems myself.

(BTW - debugging boost builds is generally quite painful, so I really need your help for this!)

comment:6 Changed 9 years ago by stooee+macports@…

the main.log is already attached. do i need to attach a 3rd one?

comment:7 Changed 9 years ago by adfernandes (Andrew Fernandes)

No, no... silly me, my mistake - sorry! I was trying to get the error output of the bootstrap.sh command.

Hmm... I'm not sure why this is failing. There appears to be no debugging output other than "booststrap.sh" returned a nonzero error... hmm... let me think about this...

comment:8 Changed 9 years ago by adfernandes (Andrew Fernandes)

Resolution: worksforme
Status: newclosed

I tried reproducing, and could not reproduce the error.

In the meantime, I updated boost to 1.47.0 (see #30202).

My suggestion is to clean and upgrade your entire macports tree. Use something like:

sudo port -vd clean all
sudo port -vd selfupdate
sudo port -vd upgrade outdated

and then try to install boost.

Note: See TracTickets for help on using tickets.