Opened 16 years ago

Closed 16 years ago

#3012 closed defect (duplicate)

BUG: fortune fails to install on Tiger due to dependancy on libcompat which fails to compile

Reported by: bahamat@… Owned by: eric@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

Output follows:

$ port install fortune ---> Fetching libcompat ---> Attempting to fetch libcompat-4.6.2-RELEASE.tar.bz2 from http://distfiles-od.opendarwin.org/ ---> Verifying checksum(s) for libcompat ---> Extracting libcompat ---> Applying patches to libcompat ---> Configuring libcompat ---> Building libcompat with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat" && LDADD=-install_name\ /opt/local/lib/libcompat.1.dylib bsdmake all" returned error 1 Command output: Warning: Object directory not changed from original /opt/local/var/db/dports/ build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/ascftime.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/cftime.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/ftime.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/getpw.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/gtty.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.1/stty.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/cfree.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/lsearch.c cc -O -pipe -DLIBC_SCCS -DSYSLIBC_SCCS -I/opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/../libc/locale -fno-common -c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c:50:20: error: regexp.h: No such file or directory /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c:55: error: parse error before '*' token /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c:55: warning: data definition has no type or storage class /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c: In function 're_comp': /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat/4.3/regex.c:73: warning: assignment makes pointer from integer without a cast * Error code 1

Stop in /opt/local/var/db/dports/build/ file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_devel_libcompat/ work/libcompat.

Error: The following dependencies failed to build: libcompat

Change History (2)

comment:1 Changed 16 years ago by mww@…

Owner: changed from darwinports-bugs@… to eric@…
Summary: fortune fails to install on Tiger due to dependancy on libcompat which fails to compileBUG: fortune fails to install on Tiger due to dependancy on libcompat which fails to compile

comment:2 Changed 16 years ago by mww@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 2998 *

Note: See TracTickets for help on using tickets.