Opened 9 years ago

Closed 7 years ago

#30162 closed defect (fixed)

meinproc4 segfaults at end of build

Reported by: nerdling (Jeremy Lavergne) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: kde Cc: mkae (Marko Käning), ddennedy (Dan Dennedy)
Port: kde kdenlive kmymoney4-devel kmymoney4

Description (last modified by nerdling (Jeremy Lavergne))

Same old worthless crash from meinproc4. This drives the KDE folks crazy. This one is from kdebase4:

/bin/sh: line 1: 95059 Segmentation fault      /opt/local/bin/meinproc4 --check --cache /opt/local/var/macports/build/_Users_aeetes_dports_kde_kdebase4/kdebase4/work/build/konsole/doc/manual/index.cache.bz2 /opt/local/var/macports/build/_Users_aeetes_dports_kde_kdebase4/kdebase4/work/kdebase-4.6.5/konsole/doc/manual/index.docbook

Change History (30)

comment:1 Changed 9 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

comment:2 Changed 9 years ago by mkae (Marko Käning)

I see the same suddenly with skrooge (r81433). :-(

comment:3 Changed 9 years ago by nerdling (Jeremy Lavergne)

The work around I recommend is running the meinproc4 command manually. You can do this by becoming root and then copy/pasting the line of code from the MacPorts log.

comment:4 Changed 9 years ago by mkae (Marko Käning)

I guess due to r81472 this ticket can be considered closed.

comment:5 Changed 9 years ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: newclosed

Potential fix applied in r81472.

comment:6 Changed 9 years ago by nerdling (Jeremy Lavergne)

Port: kdebase4 removed

comment:7 Changed 9 years ago by nerdling (Jeremy Lavergne)

Keywords: kde added
Port: kde added; kdelibs4 removed
Resolution: fixed
Status: closedreopened

This continues to happen in lots of KDE ports even with docbook-xsl-ns added.

comment:8 Changed 9 years ago by nerdling (Jeremy Lavergne)

Description: modified (diff)
Summary: kdebase4: meinproc4 segfaults at end of buildmeinproc4 segfaults at end of build
Version: 1.9.992.0.0

comment:9 Changed 9 years ago by nerdling (Jeremy Lavergne)

Cc: sharky@… added

comment:10 Changed 9 years ago by nerdling (Jeremy Lavergne)

If anyone has a chance, please try rebuilding an impacted KDE port after adding this:

build.asroot yes

comment:11 Changed 9 years ago by nerdling (Jeremy Lavergne)

By using build.asroot I was able to build marble without meinproc setfaulting. r81664.

comment:12 Changed 9 years ago by nerdling (Jeremy Lavergne)

The issue is now relegated to only when the user requests variant +docs. However, it's still a problem at that point.

Last edited 7 years ago by nerdling (Jeremy Lavergne) (previous) (diff)

comment:13 Changed 9 years ago by ryandesign (Ryan Schmidt)

The buildbot failed to build kdenlive because of the issue reported in this ticket.

comment:14 Changed 9 years ago by nerdling (Jeremy Lavergne)

Cc: dan@… added
Port: kdenlive added
Version: 2.0.0

comment:15 Changed 9 years ago by mkae (Marko Käning)

Same thing happened again for me with kmymoney4-devel port. I had to use build.asroot set to yes, otherwise it wouldn't work, although it worked on my own machine without trouble. It looks like that buildbot's environment seems to be different for some reason, which triggers this bug.

It looks like we'll have to try to hunt down this bug in meinproc4's sources ourselves, since the KDE folks aren't really focused on Mac OS X...

comment:16 Changed 9 years ago by mkae (Marko Käning)

Port: kmymoney4-devel kmymoney4 added

comment:17 Changed 8 years ago by jmroot (Joshua Root)

Is there a crash log anywhere for this?

comment:18 Changed 8 years ago by mkae (Marko Käning)

Except the above error message there is no other crash log...

The question is how could one generate more info to debug this issue?

I tried debugging this with gdb, but got NO error:

$ sudo gdb /opt/macports-test/bin/meinproc4
GNU gdb (GDB) 7.5
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-apple-darwin10.8.0".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
(gdb) set args --check --cache /opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kmymoney4-devel/kmymoney4-devel/work/build/doc/index.cache.bz2 /opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kmymoney4-devel/kmymoney4-devel/work/kmymoney/doc/index.docbook
.
.
.
/opt/macports-test/share/xsl/docbook-xsl/html/math.xsl:5: element stylesheet: error : Reference to namespace 'mml' not in scope
[Inferior 1 (process 44416) exited normally]
(gdb)

comment:19 Changed 7 years ago by mkae (Marko Käning)

At least for kmymoney4-devel r103781 should solve this issue by correctly omitting the API handbook generation eventually.

comment:20 Changed 7 years ago by michaelld (Michael Dickens)

Cc: michaelld@… removed

Cc Me!

comment:21 in reply to:  13 Changed 7 years ago by nerdling (Jeremy Lavergne)

Replying to ryandesign@…:

The buildbot failed to build kdenlive because of the issue reported in this ticket.

Consider attaching the build logs: when the slaves roll over the build numbers or otherwise get cleaned, we lose all the old build logs.

comment:22 in reply to:  18 Changed 7 years ago by nerdling (Jeremy Lavergne)

Replying to mk@…:

I tried debugging this with gdb, but got NO error:

$ sudo gdb /opt/macports-test/bin/meinproc4

Can you run this again as the build user rather than root? Perhaps using sudo -u macports gdb… or simply su'ing to the macports user.

comment:23 Changed 7 years ago by mkae (Marko Käning)

Just a few moments ago I updated https://bugs.kde.org/show_bug.cgi?id=261509 ...

Well, it's impossible to know when and where meinproc4 is going to crash...

My current approach is to simply try it a couple of times until it succeeds. :-(

comment:24 in reply to:  18 ; Changed 7 years ago by jmroot (Joshua Root)

Replying to mk@…:

Except the above error message there is no other crash log...

Logs for crashes during builds should end up in /Library/Logs/DiagnosticReports (I just confirmed this with a test port that builds and runs a test program with a deliberate null pointer dereference).

comment:25 Changed 7 years ago by sharky@…

Cc: sharky@… removed

comment:26 Changed 7 years ago by ryandesign (Ryan Schmidt)

Similar meinproc4 crash reported in #41575.

comment:27 in reply to:  24 Changed 7 years ago by mkae (Marko Käning)

Replying to jmr@…:

Logs for crashes during builds should end up in /Library/Logs/DiagnosticReports

Good to know! Will check that out next time it happens. Thanks for the hint.

comment:28 Changed 7 years ago by mkae (Marko Käning)

Marked #41575 and #41326 as duplicates of this issue.

comment:29 Changed 7 years ago by mkae (Marko Käning)

Fixed in r114083 (see #41326)!

comment:30 Changed 7 years ago by mkae (Marko Käning)

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.