Opened 12 years ago

Closed 12 years ago

#30536 closed defect (duplicate)

qt4-mac: Undefined symbols _kCWPowerDidChangeNotification etc

Reported by: alexey@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.0.0
Keywords: lion Cc:
Port: qt4-mac

Description (last modified by ryandesign (Ryan Schmidt))

Qt4 fails to link under OSX Lion:

:info:build /Developer/usr/bin/llvm-g++-4.2 -headerpad_max_install_names -arch x86_64 -Wl,-syslibroot,/Developer/SDKs/MacOSX10.7.sdk -single_module -dynamiclib -Xarch_x86_64 -mmacosx-version-min=10.7 -Xarch_x86_64 -mmacosx-version-min=10.7 -o libqcorewlanbearer.dylib .obj/release-shared/main.o .obj/release-shared/qcorewlanengine.o .obj/release-shared/qnetworksession_impl.o .obj/release-shared/moc_qcorewlanengine.o .obj/release-shared/moc_qnetworksession_impl.o .obj/release-shared/moc_qbearerengine_impl.o    -framework Foundation -framework SystemConfiguration -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt4-mac/qt4-mac/work/qt-everywhere-opensource-src-4.7.3/lib -lQtNetwork -lQtCore  
:info:build Undefined symbols for architecture x86_64:
:info:build   "_kCWPowerDidChangeNotification", referenced from:
:info:build       -[QNSListener init] in qcorewlanengine.o
:info:build   "_kCWAssocKey8021XProfile", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_kCWScanKeySSID", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_kCWScanKeyRestTime", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build       QScanThread::run()      in qcorewlanengine.o
:info:build   "_kCWScanKeyScanType", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build       QScanThread::run()      in qcorewlanengine.o
:info:build   "_kCWScanKeyMerge", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build       QScanThread::run()      in qcorewlanengine.o
:info:build   "_kCWAssocKeyPassphrase", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_SecKeychainSearchCreateFromAttributes", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_SecKeychainSearchCopyNext", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_SecKeychainItemCopyContent", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_SecKeychainItemFreeContent", referenced from:
:info:build       QCoreWlanEngine::connectToId(QString const&)  in qcorewlanengine.o
:info:build   "_OBJC_CLASS_$_CWInterface", referenced from:
:info:build       objc-class-ref in qcorewlanengine.o
:info:build   "_OBJC_CLASS_$_CW8021XProfile", referenced from:
:info:build       objc-class-ref in qcorewlanengine.o
:info:build ld: symbol(s) not found for architecture x86_64

(full log attached below)

Attachments (1)

main.log.gz (353.2 KB) - added by alexey@… 12 years ago.
Build log

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by alexey@…

Attachment: main.log.gz added

Build log

comment:1 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: michaelld@… removed
Description: modified (diff)
Keywords: lion added
Owner: changed from macports-tickets@… to michaelld@…
Port: qt4-mac added
Summary: Qt4 linking error under OSX Lionqt4-mac: Undefined symbols _kCWPowerDidChangeNotification etc

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #30346.

Note: See TracTickets for help on using tickets.