Opened 10 years ago

Closed 10 years ago

#30544 closed defect (duplicate)

ffcall build failed

Reported by: taro2001@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc:
Port: ffcall

Description

Log:

:notice:build --->  Building ffcall
:debug:build Executing org.macports.build (ffcall)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MA
COSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10" && /usr/bin/make -j2 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10" && /usr/bin/make -j2 -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10'
:info:build cd avcall; /usr/bin/make all
:info:build make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10/avcall'
:info:build /usr/bin/gcc-4.2 -E `if test true = true; then echo '-DASM_UNDERSCORE'; fi` ./avcall-i386-macro.S | grep -v '^ *#line' | grep -v '^#ident' | grep -v '^#' | sed -e 's,% ,%,g' -e 's,% ,%,g' -e 's,\. ,.,g' > avcall-i386.s
:info:build /bin/sh ./libtool --mode=compile /usr/bin/gcc-4.2 -O2 -arch x86_64 -c ./structcpy.c
:info:build /bin/sh ./libtool --mode=compile /usr/bin/gcc-4.2 -x none -c avcall-i386.s
:info:build /usr/bin/gcc-4.2 -O2 -arch x86_64 -c ./structcpy.c -o structcpy.o
:info:build /usr/bin/gcc-4.2 -x none -c avcall-i386.s -o avcall-i386.o
:info:build avcall-i386.s:7:suffix or operands invalid for `push'
:info:build avcall-i386.s:9:suffix or operands invalid for `push'
:info:build avcall-i386.s:10:suffix or operands invalid for `push'
:info:build avcall-i386.s:39:suffix or operands invalid for `call'
:info:build avcall-i386.s:47:suffix or operands invalid for `call'
:info:build avcall-i386.s:53:suffix or operands invalid for `call'
:info:build avcall-i386.s:168:suffix or operands invalid for `pop'
:info:build avcall-i386.s:169:suffix or operands invalid for `pop'
:info:build avcall-i386.s:171:suffix or operands invalid for `pop'
:info:build make[1]: *** [avcall-i386.lo] Error 1
:info:build make[1]: *** Waiting for unfinished jobs....
:info:build echo timestamp > structcpy.lo
:info:build make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10/avcall'
:info:build make: *** [all] Error 2
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/work/ffcall-1.10" && /usr/bin/make -j2 -w all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for ffcall): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for ffcall is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ffcall/ffcall/main.log

Change History (1)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #23020; please search before filing new tickets.

Note: See TracTickets for help on using tickets.