Opened 10 years ago

Closed 10 years ago

#30557 closed defect (duplicate)

cannot build any of geos, atlas and more

Reported by: typhoon.man@… Owned by: opendarwin@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc:
Port: geos

Description (last modified by mf2k (Frank Schima))

[typhoon@Tue Aug 02] /~:sudo port install geos
--->  Fetching archive for geos
--->  Attempting to fetch geos-3.3.0_0.darwin_11.x86_64.tbz2 from http://packages.macports.org/geos
--->  Fetching geos
--->  Attempting to fetch geos-3.3.0.tar.bz2 from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/geos
--->  Verifying checksum(s) for geos
--->  Extracting geos
--->  Configuring geos
--->  Building geos
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for geos is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_geos/geos/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments (1)

main.log (454.6 KB) - added by typhoon.man@… 10 years ago.
main.log file

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: geos build failed status 1 removed
Milestone: MacPorts 2.0.2
Owner: changed from macports-tickets@… to opendarwin@…
Priority: HighNormal

Please attach the log so we can debug the problem.

comment:2 in reply to:  1 Changed 10 years ago by typhoon.man@…

Replying to macsforever2000@…:

Please attach the log so we can debug the problem.

do i have to attach the whole mail.log file?

Changed 10 years ago by typhoon.man@…

Attachment: main.log added

main.log file

comment:3 Changed 10 years ago by typhoon.man@…

I use the latest version of MacPorts on Mac OS Lion. I also tried to uninstall the Macports and start it from scratch. Got the same error

comment:4 Changed 10 years ago by Veence (Vincent)

For atlas, this is normal. Please see #30280 for a solution. Geos does not seem to compile with clang due to source errors (clang is more strict than GCC). I've signaled this upstream, since I was unable to find a quick patch, but in August, the response may be slow…

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

The geos problem is a duplicate of #30309. Please keep your tickets confined to one issue per ticket.

Note: See TracTickets for help on using tickets.