Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#30560 closed defect (duplicate)

p5-net-libidn install not finding libidn

Reported by: abh (Ask Bjørn Hansen) Owned by: mni@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: p5-net-libidn

Description

When compiling p5-net-libidn, the configure step says it can't link with libidn. The latest libidn port is installed (and worked for curl etc).

:debug:configure Executing org.macports.configure (p5-net-libidn)
:debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.7' CXX='/Developer/usr/bin/clang++' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/.CC_PRINT_OPTIONS' F90FLAGS='-O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' FCFLAGS='-O2 -m64' OBJC='/Developer/usr/bin/clang' INSTALL='/usr/bin/install -c' PERL_AUTOINSTALL='--skipdeps' OBJCFLAGS='-O2 -arch x86_64' FFLAGS='-O2 -m64' CC_PRINT_OPTIONS='YES' CC='/Developer/usr/bin/clang'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor'
:debug:configure Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12" && /opt/local/bin/perl Makefile.PL INSTALLDIRS=vendor 
:info:configure ld: library not found for -lidn
:info:configure clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:configure This module requires GNU Libidn, which could not be found.
:debug:build build phase started at Tue Aug  2 19:06:17 PDT 2011
:notice:build --->  Building p5-net-libidn
:debug:build Executing org.macports.build (p5-net-libidn)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12" && /usr/bin/make -j2 -w all'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12" && /usr/bin/make -j2 -w all 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12'
:info:build make: *** No rule to make target `all'.  Stop.
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12'
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_perl_p5-net-libidn/p5-net-libidn/work/Net-LibIDN-0.12" && /usr/bin/make -j2 -w all " returned error 2

Change History (5)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to mni@…
Port: p5-net-libidn added

This looks like a duplicate of #28220. Does the patch attached there help?

comment:2 in reply to:  1 ; Changed 9 years ago by abh (Ask Bjørn Hansen)

Replying to ryandesign@…:

This looks like a duplicate of #28220. Does the patch attached there help?

Sorta -- removing the files/patch-Makefile.PL.diff file (and the related line in the Portfile) and removing all the post-patch lines, but adding

configure.args-append   --with-libidn=${prefix}/lib --with-libidn-inc=${prefix}/include

does make it work.

Not sure if the problem is that with the Xcode version I use /Developer/usr/bin/clang is the default compiler, rather than gcc?

comment:3 Changed 9 years ago by abh (Ask Bjørn Hansen)

(Also, thank you for the prompt feedback earlier!)

comment:4 in reply to:  2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Replying to ask@…:

Not sure if the problem is that with the Xcode version I use /Developer/usr/bin/clang is the default compiler, rather than gcc?

Good guess... I can confirm the build fails with clang on Snow Leopard. But the proposed fix did not fix it for me. I committed a fix that does work for me in r81637.

comment:5 Changed 9 years ago by abh (Ask Bjørn Hansen)

Excellent - thanks again Ryan!

Note: See TracTickets for help on using tickets.