Opened 10 years ago

Closed 6 years ago

#30574 closed defect (wontfix)

macports_fastload.tcl: too many levels of symbolic links

Reported by: alantech@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 2.0.1
Keywords: Cc: ryandesign (Ryan Schmidt), vulcan_@…, alton@…, macports.good@…
Port:

Description (last modified by jmroot (Joshua Root))

After installing MacPorts 2.0.1 on a new machine (i.e. no prior version installed,) I get the following error messages in trying to access the port command for anything:

couldn't read file "/opt/local/share/macports/Tcl/macports1.0/macports_fastload.tcl": too many levels of symbolic links
    while executing
"source [file join "/opt/local/share/macports/Tcl" macports1.0 macports_fastload.tcl]"
    (file "/opt/local/bin/port" line 37)

In examining /opt/local/share/macports/Tcl/macports1.0, I find that it is a symlink that points to /opt/local/share/macports/Tcl/macports1.0, in other words, a circular link.

Attachments (3)

macportsproblem.txt (56.7 KB) - added by vulcan_@… 10 years ago.
verbose output of "port selfupdate"
lowbatteries-install.log (9.1 KB) - added by macports.good@… 10 years ago.
install.log for MacPorts-2.0.3 on Lion
install.log (10.5 KB) - added by alantech@… 10 years ago.
My install log from MacPorts 2.0.3 on Lion 10.7.1

Download all attachments as: .zip

Change History (20)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Milestone: MacPorts Future

How did you install?

comment:2 in reply to:  1 Changed 10 years ago by alantech@…

Replying to jmr@…:

How did you install?

Fresh install onto a new system with Lion pre-installed using the DMG package.

comment:3 Changed 10 years ago by vulcan_@…

I see the same problem updating from pre-2.0 version macports to version 2.0.1 via selfupdate. I am on Snow Leopard 10.6.8

I have attached the verbose output of the selfupdate. I have not been able to isolate the place where it blows away the folder and replaces it with the bad link .. but it must be in there somewhere.

Changed 10 years ago by vulcan_@…

Attachment: macportsproblem.txt added

verbose output of "port selfupdate"

comment:4 Changed 10 years ago by alton@…

I as well am having this problem with Lion. I have tried with 2.0.1 (both source and install binary) as well as 2.0.0 (also both source and binary). Both fail with this same error. I originally tried to do a selfupdate, however this failed with this error. I was unable to uninstall macports as it was broken so I deleted the various paths to start over (/opt/local/...). I am curious if this a problem for all of us Lions out there or is it a subset of us that are broken.

And yes everytime I see the bad link. :-)

comment:5 Changed 10 years ago by alton@…

Tried removing and installing xcode as well as checking out the latest from SVN. Still same error.

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: Bug: MacPorts 2.0.1 "too many levels of symbolic links"macports_fastload.tcl: too many levels of symbolic links

I'm sure I've fielded this question before recently, but I cannot find it now. I presume the problem is that /opt/local/share/macports/Tcl/macports1.0 is a symlink to itself? Or is it that /opt/local/share/macports/Tcl is a symlink to /Library/Tcl? A solution to that would be to remove /opt/local/share/macports/Tcl and install MacPorts again.

comment:7 in reply to:  6 Changed 10 years ago by alantech@…

Replying to ryandesign@…:

I'm sure I've fielded this question before recently, but I cannot find it now. I presume the problem is that /opt/local/share/macports/Tcl/macports1.0 is a symlink to itself? Or is it that /opt/local/share/macports/Tcl is a symlink to /Library/Tcl? A solution to that would be to remove /opt/local/share/macports/Tcl and install MacPorts again.

No joy. The file is created as a symlink to itself. And before you ask, /Library/Tcl does not exist and is not created by the install.

comment:8 Changed 10 years ago by macports.good@…

I've fully removed Xcode and Macports from my system, then reinstalled Xcode, then Macports, and I get this issue as well. I've tried the latest version, as well as svn trunk, and 2.0.0, all with the exact same circular symlink.

comment:9 Changed 10 years ago by alton@…

Tried with 2.0.3 and it still doesn't work. Still have the "/opt/local/share/macports/Tcl/macports1.0 -> /opt/local/share/macports/Tcl/macports1.0" symlink.

I have dug and dug on this and can't find the issue. Does anyone have a clue? The inability to use all my ports or reinstall them (I removed them in my uninstall/ reinstall troubleshooting method) is a pretty big issue. Any word from the maintainer? Does this work for others and all of us on here are tickling some pesky bug?

comment:10 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: vulcan_@… alton@… macports.good@… added

I've installed MacPorts using the dmg and compiled by hand on many Macs over the years and never seen this problem so I'm still a bit in the dark about it.

@macports.good: How did you remove Xcode and MacPorts? What version of Xcode did you reinstall? How did you reinstall MacPorts? If compiled by hand, what configure arguments? Did you specify --with-tclpackage? If not, does the problem resolve if you do (e.g. --with-tclpackage=/opt/local/share/macports/Tcl)? What OS version?

comment:11 Changed 10 years ago by macports.good@…

I removed MacPorts with the nuclear option:

sudo rm -v -rf /opt/local /Applications/DarwinPorts /Applications/MacPorts /Library/LaunchDaemons/org.macports.* /Library/Receipts/DarwinPorts*.pkg /Library/Receipts/MacPorts*.pkg /Library/StartupItems/DarwinPortsStartup /Library/Tcl/darwinports1.0 /Library/Tcl/macports1.0 ~/.macports /opt/mports /private/var/db/receipts/org.macports.MacPorts.*

Same with Xcode:

/Library/Developer/4.1/uninstall-devtool; rm -rf /Library/Developer/;

Then, I downloaded and installed the latest version of Xcode from the App Store, then installed MacPorts from MacPorts-2.0.3-10.7-Lion.dmg. What I end up with is a broken soft link at /opt/local/share/macports/Tcl/macports1.0 and the file macports_fastload.tcl exists nowhere on my system.

comment:12 Changed 10 years ago by blb@…

Output from Installer.app should be in /var/log/install.log; can you attach the last MacPorts install output from that file (not the whole file since it'll show lots of other stuff)?

Changed 10 years ago by macports.good@…

Attachment: lowbatteries-install.log added

install.log for MacPorts-2.0.3 on Lion

comment:13 Changed 10 years ago by macports.good@…

It seems that in addition to the "nuclear option" I used above, I needed to also completely delete /Library/Tcl (which seemed to be a broken link), then I ran the installer and everything works.

I also tested installing in a virtual machine with a fresh install of Lion, and it worked fine. So the issue somehow seems to be upgrading from Snow Leopard to Lion.

comment:14 Changed 10 years ago by vulcan_@…

please note my input from 6 weeks back .. i tried to upgrade my macports 1.9.6 installation to 2.0.1 and saw the same failure. I restored the /opt/local/shared/macports dir from Time Machine and tried it again with 2.0.3 .. still have the same problem. I was NOT doing an OS upgrade .. i was on Snow Leopard only.

comment:15 Changed 10 years ago by macports.good@…

Right, lost my head there for a bit - this happens when upgrading from 1.x to 2.x, not during OS update. I was able to install 1.x using SVN on Lion, then did an upgrade, and had the same problem.

Changed 10 years ago by alantech@…

Attachment: install.log added

My install log from MacPorts 2.0.3 on Lion 10.7.1

comment:16 Changed 10 years ago by alton@…

I too had done the "Nuclear" option several times to no avail. I had however not noticed the broken link at '/Library/Tcl'.

I removed the broken Tcl link as well as macports. Once that was done I checked out the latest from SVN configured and compiled it. Now it appears to work fine.

All along it was the fact that '/Library/Tcl' was pointing to a path under '/opt/local/...' somewhere that no longer existed.

Thanks macports.good@…, you pointed me in the right direction.

comment:17 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: wontfix
Status: newclosed

We use our own Tcl now, so I don’t think this is relevant anymore.

Note: See TracTickets for help on using tickets.