New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #30583 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

ncurses, libpixman: build error with nawk

Reported by: phil@… Owned by: jmr@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: ryandesign@…, toby@…
Port: ncurses nawk libpixman

Description

I'm trying to upgrade my outdated ports after selfupdating to Macports 2.0.1. It fails on both ncurses and libpixman, which my remaining upgrades depend on. (grails-devel worked just fine.)

Specific error:

--->  Configuring ncurses
--->  Building ncurses
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for ncurses is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_ncurses/ncurses/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

Steps I've tried:

  • port clean ncurses
  • port clean --all ncurses
  • port clean --all outdated
  • Rebooting

Uninstalling would remove a lot of dependencies, and I don't believe that is the issue. All of the MacPorts issues I've found that sound even similar (ex: #29921, #26791) are closed as duplicates or as "WorksForMe". None have workarounds.

System info:

  • Snow Leopard: 10.6.8
  • XCode:
    Xcode 3.2.6
    Component versions: DevToolsCore-1809.0; DevToolsSupport-1806.0
    BuildVersion: 10M2518
    
  • MacPorts: 2.0.1

I'm not planning on upgrading XCode to version 4, and the manual doesn't list it as a requirement.

The full log is attached. I wasn't sure what was relevant.

Attachments

main.log (47.1 KB) - added by phil@… 3 years ago.
main.log for ncurses

Change History

Changed 3 years ago by phil@…

main.log for ncurses

comment:1 Changed 3 years ago by ryandesign@…

  • Keywords ncurses error upgrade removed
  • Owner changed from macports-tickets@… to jmr@…
  • Summary changed from ncurses - Error: Unable to upgrade port: 1 to ncurses: build error with nawk

You appear to have nawk installed. Try uninstalling or at least deactivating nawk while trying to build ncurses. nawk has been implicated in other port failures like #30239.

sudo port clean ncurses
sudo port -f deactivate nawk
sudo port install ncurses

And then if desired:

sudo port activate nawk

comment:2 Changed 3 years ago by ryandesign@…

  • Cc ryandesign@… added

Let us know if libpixman then also succeeds; if not attach that main.log.

comment:3 Changed 3 years ago by phil@…

OK, I went one further - I completely removed nawk. (I don't know how it got installed, because I don't even know what it is!). That seems to have fixed it. It didn't even occur to me that having it installed was the issue - it looked like it was part of the build process.

Thank you - that was incredibly frustrating.

libpixman seems to have worked as well. All my ports are now updated.

Thanks again.

comment:4 Changed 3 years ago by jmr@…

  • Cc toby@… added
  • Port changed from ncurses to ncurses nawk

comment:5 Changed 3 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to fixed

comment:6 Changed 3 years ago by ryandesign@…

  • Port changed from ncurses nawk to ncurses nawk libpixman
  • Summary changed from ncurses: build error with nawk to ncurses, libpixman: build error with nawk

Perhaps it would be appropriate for us to modify ncurses and libpixman{,-devel} to force the use of /usr/bin/awk? We've done that in other ports for other reasons (#30308).

comment:7 Changed 3 years ago by ryandesign@…

I've done this for libpixman{,-devel} in r81677.

Note: See TracTickets for help on using tickets.