Opened 10 years ago

Closed 10 years ago

#30715 closed defect (duplicate)

mod_perl2 fails to install on Lion (with solution)

Reported by: lbn@… Owned by: ryan@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc:
Port: mod_perl2

Description

When installing Apache2 (needed for mod_perl) Perl5.12 gets installed.

Perl5.12 is configured without USE_ITHREAD, which cause mod_perl2 to fail.

I recompiled perl5.12 with USE_ITHREAD defined in config.h, now mod_perl2 installs

Change History (4)

comment:1 Changed 10 years ago by lbn@…

Cc: lbn@… added

Cc Me!

comment:2 Changed 10 years ago by lbn@…

Cc: lbn@… removed

Cc Me!

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Keywords: lion added; mod_perl2 removed
Milestone: MacPorts 2.0.2
Owner: changed from macports-tickets@… to ryan@…
Port: mod_perl2 added
Priority: HighNormal

As per the ticket guidelines, please put the name of the port in the Port field, don't set the Milestone field, and note that the High priority is reserved for the use of MacPorts team members.

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Keywords: lion removed
Resolution: duplicate
Status: newclosed

Duplicate of #23993; please search before filing new tickets.

Note: See TracTickets for help on using tickets.