Opened 8 years ago

Closed 8 years ago

#30828 closed defect (fixed)

rogue build fails on Lion w/ Xcode 4.2 (CC_PRINT_OPTIONS error)

Reported by: kristen@… Owned by: aschenke@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: lion, xcode 4.2, clang Cc: hooby3d@…
Port: rogue

Description (last modified by mf2k (Frank Schima))

Seems to be failing on .CC_PRINT_OPTIONS

:info:build clang: error: unable to open CC_PRINT_OPTIONS file: Error opening output file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/work/.CC_PRINT_OPTIONS'
:info:build clang: error: unable to open CC_PRINT_OPTIONS file: Error opening output file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/work/.CC_PRINT_OPTIONS'

Attachments (3)

main.log (4.8 KB) - added by kristen@… 8 years ago.
main.2.log (17.9 KB) - added by hooby3d@… 8 years ago.
hooby3d install log
CC_PRINT_OPTIONS (89.4 KB) - added by hooby3d@… 8 years ago.

Download all attachments as: .zip

Change History (21)

Changed 8 years ago by kristen@…

Attachment: main.log added

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: lion added
Owner: changed from macports-tickets@… to aschenke@…

comment:2 Changed 8 years ago by aschenke@…

Status: newassigned

comment:3 Changed 8 years ago by aschenke@…

What version of Xcode are we talking about here? I notice that your system is trying to compile with clang, while mine (Xcode 4.1) uses llvm-gcc-4.2 and seems to compile and work fine.

comment:4 Changed 8 years ago by kristen@…

As I mentioned in the title, this is iOS 5, Beta 4, so Xcode is version 4.2. I have another system using 4.1 and it compiled fine there. I noticed that it was using clang. There is a related bug (sorry, I don't have the number handy, but you can search for it) where Xaw3d doesn't compile either, so xemacs doesn't compile.

comment:5 Changed 8 years ago by aschenke@…

You're right... I was just checking and there seems to be some issue with Xcode 4.2 and Macports, as other ports are having similar errors. Unfortunately I don't have access to Xcode 4.2, so I can't do anything to resolve this at moment. But it seems likely that Macports itself will be patched to fix the underlying problem.

Thanks for reporting the issue, and I'll investigate the issue some more.

comment:6 Changed 8 years ago by kristen@…

Sure, NP. I appreciate you looking at it. Xcode 4.2 is likely to be real before long, so this will have to be dealt with soon, I suspect.

comment:7 Changed 8 years ago by aschenke@…

Keywords: xcode 4.2 clang added

comment:8 Changed 8 years ago by aschenke@…

Summary: rogue fails to build on Lion with pre-release Xcode (iOS Beta 4)rogue build fails on Lion w/ Xcode 4.2 (CC_PRINT_OPTIONS error)

Similar tickets: #30345 and #30776

comment:9 Changed 8 years ago by aschenke@…

I've tried this with the release version of Xcode 4.2 and it works ok for me. Is anyone still having this issue?

comment:10 in reply to:  9 Changed 8 years ago by kristen@…

Replying to aschenke@…:

I've tried this with the release version of Xcode 4.2 and it works ok for me. Is anyone still having this issue?

Still fails for me. Note that I have iOS tools installed, so clang everywhere. The stock Lion dev tools may be different.

[Kristens-MBP:~] root# port install rogue ---> Computing dependencies for rogue ---> Building rogue Error: Target org.macports.build returned: shell command failed (see log for details) Log for rogue is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/main.log

Looking at the log, the error seems the same as before:

:info:build clang: clang: error: unable to open CC_PRINT_OPTIONS file: Error opening output file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/work/.CC_PRINT_OPTIONS' :info:build error: unable to open CC_PRINT_OPTIONS file: Error opening output file '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/work/.CC_PRINT_OPTIONS'

comment:11 Changed 8 years ago by aschenke@…

Unfortunately, I'm still not able to reproduce this issue. Using Xcode 4.2.1 it compiles rogue with clang ok for me. Have you tried installing rogue with the latest version of MacPorts (2.0.3)? Do any other ports exhibit this behavior? Have you tried cleaning the port ("port clean --all rogue") to see if that helps?

comment:12 Changed 8 years ago by aschenke@…

Resolution: worksforme
Status: assignedclosed

comment:13 in reply to:  description Changed 8 years ago by hooby3d@…

Resolution: worksforme
Status: closedreopened

I am getting the same error (log attached); the file (.CC_PRINT_OPTIONS, also attached) exists - could this be a permissions issue? Happens with both clang and gcc. Lion/Xcode 4.3.1

comment:14 Changed 8 years ago by hooby3d@…

Cc: hooby3d@… added

Cc Me!

Changed 8 years ago by hooby3d@…

Attachment: main.2.log added

hooby3d install log

Changed 8 years ago by hooby3d@…

Attachment: CC_PRINT_OPTIONS added

comment:15 Changed 8 years ago by kristen@…

Still broken for me too. They closed the bug before I could check again back a couple of months ago. You can temporarily get it to work by cd-ing to the build directory (something like /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_games_rogue/rogue/work/rogue5.4.4 - check the log, though, for the right directory), sudo make, and then do 'sudo port install rogue' again. It's still fundamentally broken, though. Latest Xcode I've tested with is 4.3.2 (4E2002). I think there's a real problem here, so instead of just blowing this off with 'works for me', how about really looking into it.

comment:16 Changed 8 years ago by aschenke@…

Should hopefully be fixed in r91896. Please get the update and let me know the outcome.

comment:17 in reply to:  16 Changed 8 years ago by kristen@…

Replying to aschenke@…:

Should hopefully be fixed in r91896. Please get the update and let me know the outcome.

Yay, at last!

[Users/kristen] > install rogue Warning: Xcode appears to be installed but xcodebuild is unusable; some ports will likely fail to build. Warning: You may need to run sudo xcode-select -switch /Applications/Xcode.app ---> Computing dependencies for rogue ---> Fetching archive for rogue ---> Attempting to fetch rogue-5.4.4_2.darwin_11.x86_64.tbz2 from http://packages.macports.org/rogue ---> Fetching rogue ---> Verifying checksum(s) for rogue ---> Extracting rogue ---> Configuring rogue ---> Building rogue ---> Staging rogue into destroot ---> Installing rogue @5.4.4_2 ---> Activating rogue @5.4.4_2 ---> Cleaning rogue

comment:18 Changed 8 years ago by aschenke@…

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.