Opened 9 years ago

Closed 9 years ago

#30854 closed defect (fixed)

nedit on lion is aborted

Reported by: linkofhyrule@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: lion Cc: mfuhrer@…, tim.gomeringer@…
Port: nedit

Description

I installed nedit on my mac with lion 10.7 via mac ports. the installation went fine. but when i tried to run it i got the following error message.

locale not supported by Xlib, locale set to C
Abort trap: 6

I tried setting LANG=eng_US but that only changed the error message to this:

locale not supported by C library, locale unchanged
Abort trap: 6

I couldn't find any solution on the net. Any ideas what might help?

Change History (12)

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Keywords: nedit removed

comment:2 Changed 9 years ago by jmroot (Joshua Root)

I can't help with why it's failing in the first place, but note that "eng_US" is not a valid locale. Run locale -a to see the available list. No doubt you meant "en_US".

comment:3 in reply to:  2 Changed 9 years ago by linkofhyrule@…

Replying to jmr@…:

I can't help with why it's failing in the first place, but note that "eng_US" is not a valid locale. Run locale -a to see the available list. No doubt you meant "en_US".

thanks for pointing that out. yeah that was a typo in the ticket here. I tried it with en_US not eng_US.

comment:4 Changed 9 years ago by mfuhrer@…

Cc: mfuhrer@… added

Cc Me!

comment:5 Changed 9 years ago by tim.gomeringer@…

Cc: tim.gomeringer@… added

Cc Me!

comment:6 in reply to:  5 Changed 9 years ago by tim.gomeringer@…

Replying to tim.gomeringer@…:

Cc Me!

Just upgraded to OSX 10.7.2 (Lion), Xcode 4.2.1, and MacPorts 2.0.3 and have the same issue describe above when I try to run nedit.

Abort trap: 6

comment:7 Changed 9 years ago by dan@…

I have the same problem. I built successfully with Mac Ports, but when I ran nedit the program exited immediately and I got error:

"Abort trap: 6"

Has anyone successfully built nedit on lion? With Mac Ports or any other way? (also, Fink's nedit does not support lion; tried building independently with target "macosx" as well but that failed too...)

I miss nedit.

comment:8 Changed 9 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #30889. Other ticket has a crash report, closing this one.

comment:9 Changed 9 years ago by dan@…

Resolution: duplicate
Status: closedreopened

#30889 listed Mac OS X 10.6.8 (10K549). This problem is for 10.7.x.

comment:10 Changed 9 years ago by econoplas@…

This looks like a bug in nedit... not a problem with MacPorts per se. Below is the unified diff of the one-liner fix. Problem was call to memset with len=256 on 255-char long array. Makes memset_chk grumpy. Bummer. I built nedit-5.5-src.tar.gz source tarball on lion (10.7.2) with OpenMotif 2.1.32 and Xcode 4.2.1 and it seems to be running just fine so far. No more abort trap: 6 at startup.

--- nedit-5.5/source/regularExp.c	2004-08-20 10:37:30.000000000 -0600
+++ nedit-5.5-macosx-lion-built/source/regularExp.c	2012-01-12 18:04:36.000000000 -0700
@@ -2645,7 +2645,7 @@
 
 /* Default table for determining whether a character is a word delimiter. */
 
-static unsigned char  Default_Delimiters [UCHAR_MAX] = {0};
+static unsigned char  Default_Delimiters [UCHAR_MAX+1] = {0};
 
 static unsigned char *Current_Delimiters;  /* Current delimiter table */
 

comment:11 Changed 9 years ago by wroberts@…

Can you provide a little guidance on how to build nedit with OpenMotif 2.1.32 and Xcode 4.2, please? Thanks in advance

comment:12 Changed 9 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: reopenedclosed

Thanks for the patch, this is now being applied as of r89222.

Note: See TracTickets for help on using tickets.