Opened 9 years ago

Closed 9 years ago

#30897 closed defect (duplicate)

ImageMagick build fails when linking to lcms/lcms2

Reported by: almond@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: lcms Cc:
Port: ImageMagick

Description

The build phase of ImageMagick is failing to find symbols when linking against the lcms library. I'm running MacOS X 10.5.8 and

ralmond@Skuld[44]% port installed lcms
The following ports are currently installed:
  lcms @1.19_2
  lcms @1.19_2+universal (active)
ralmond@Skuld[45]% port installed lcms2
The following ports are currently installed:
  lcms2 @2.2_0 (active)

A puzzling error is turning up in the configure phase:

:info:configure checking for LCMS v2... 
:info:configure checking lcms2.h usability... yes
:info:configure checking lcms2.h presence... yes
:info:configure checking for lcms2.h... yes
:info:configure checking for cmsSetLogErrorHandler in -llcms2... no
:info:configure checking if LCMS v2 package is complete... no -- some components failed test
:info:configure ./configure: line 29552: test: too many arguments
:info:configure -------------------------------------------------------------

This may be related to #29745.

Attachments (1)

main.log (360.3 KB) - added by almond@… 9 years ago.
Build log

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by almond@…

Attachment: main.log added

Build log

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to ryandesign@…

Please remember to cc the maintainer.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Can you attach the config.log please?

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Actually in your case the problem is easily explained, in that you're trying to build a universal ImageMagick, and ImageMagick uses lcms2, and lcms2 is not universal on your system. I've fixed the dependency to read lcms2 and not lcms (see #29745); please re-test with that version. (MacPorts should upgrade your lcms2 to universal before trying to build ImageMagick.)

comment:4 Changed 9 years ago by almond@…

This worked exactly as advertised.

Thanks for the quick diagnosis and fix!

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.