Opened 10 years ago

Closed 9 years ago

#30933 closed defect (wontfix)

llvm-gcc42 does not accept -march

Reported by: naromero@… Owned by: erickt@…
Priority: Normal Milestone:
Component: ports Version: 2.0.1
Keywords: Cc: mfeiri, naromero@…
Port: llvm-gcc42

Description (last modified by ryandesign (Ryan Schmidt))

The llvm-gcc42 port does not accept -march 64.

This is the error message I get,

cc1: error: unrecognized command line option "-march"

but this option should just be passed to the GNU compiler.

Change History (9)

comment:1 Changed 10 years ago by naromero@…

This looks like this bug which is supposed to be fixed: #20660

comment:2 Changed 10 years ago by naromero@…

This current bug is for the flag -march, while the older ticket is for -arch

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: llvm-gcc42 added

Is this a bug in the MacPorts portfile for llvm-gcc42, or a bug in the llvm-gcc42 software? If the latter, submit it to the developers of the software.

comment:4 Changed 10 years ago by naromero@…

Not really sure. Will need to do some digging around to figure this out.

comment:5 Changed 10 years ago by naromero@…

I asked on the llvm-dev list and they say that the problem is not in llvm but in MacPorts. Note that the problem was with -arch and not -march as I heard stated earlier.

One developer stated:

The -arch option is handled by Apple's "driver-driver", and the MacPorts build is probably not using that. See the driverdriver.c source file in llvm-gcc for details.

My follow-up

Since presumably Macports is just fetching an llvm tar ball from some repository, is the issue that llvm has been misconfigure in some obvious way? Yes, I can take a look at the driverdriver.c source file as well.

Reply by another developer: Just plain configure/make/make install won't build the driver driver. You need an apple style buildit for that. Check out the build_llvm or build_gcc scripts in the source directory for a guideline.

Should this also be working in LLVM 2.9 or is the latest SVN also needed?

2.9 should be fine.

Could someone please take look into this?

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Cc: mfeiri@… added
Owner: changed from macports-tickets@… to erickt@…

Please remember to cc the maintainers. The message in the description shows a problem with -march, but in the comments you're now saying the problem is with -arch. Which is it?

comment:7 Changed 10 years ago by naromero@…

Cc: naromero@… added

Cc Me!

comment:8 Changed 10 years ago by naromero@…

The problem is with -arch, sorry about the confusion.

comment:9 Changed 9 years ago by mfeiri

Resolution: wontfix
Status: newclosed

Thanks for your report. We prefer the standard "configure/make/make install" build process. Note that llvm-gcc is deprecated. Please consider clang if you need a (obj)c(++) compiler with support for the -arch flag.

Note: See TracTickets for help on using tickets.