Opened 7 years ago

Closed 7 years ago

#31311 closed defect (duplicate)

MPlayer @1.0rc4: ./libavutil/libm.h:63: error: static declaration of 'lrint' follows non-static declaration

Reported by: dizzy@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: MPlayer

Description

I can't build Mplayer with XCode 4.0.2 on OSX 10.6.8.

# /opt/local/bin/port install mplayer--->  Computing dependencies for mplayer--->  Fetching archive for mplayer
--->  Attempting to fetch mplayer-1.0rc4_1.darwin_10.x86_64.tbz2 from http://packages.macports.org/mplayer
--->  Fetching mplayer
--->  Verifying checksum(s) for mplayer
--->  Extracting mplayer
--->  Applying patches to mplayer
--->  Configuring mplayer
--->  Building mplayer
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for mplayer is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_multimedia_MPlayer/mplayer/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Looking into the build log file the first errors I see are:

:info:build In file included from ./libavutil/internal.h:194,
:info:build                  from libmpcodecs/vf_fspp.c:50:
:info:build ./libavutil/libm.h:63: error: static declaration of 'lrint' follows non-static declaration
:info:build ./libavutil/libm.h:77: error: static declaration of 'round' follows non-static declaration
:info:build ./libavutil/libm.h:84: error: static declaration of 'roundf' follows non-static declaration
:info:build ./libavutil/libm.h:91: error: static declaration of 'truncf' follows non-static declaration

Attachments (1)

main.log (304.6 KB) - added by dizzy@… 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by dizzy@…

Attachment: main.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #30279.

Note: See TracTickets for help on using tickets.