Opened 6 years ago

Closed 6 years ago

#31328 closed defect (fixed)

virtualbox: @4.1.2 fixing Python Bindings on Lion

Reported by: ahmed@… Owned by: royliu@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: lion haspatch Cc: royliu@…
Port: virtualbox

Description

Virtualbox currently builds VBoxPython2_6.so in Lion which segfaults, I'm attaching patches that should be applied after applying my recent patches in ticket #31305 to build VBoxPython2_7.so for Virtualbox 4.1.2

Also the old Portfile didn't copy the SDK of virtual box correctly, I've fixed that too

Attachments (5)

Portfile.patch (1.8 KB) - added by ahmed@… 6 years ago.
Portfile patch
patch-src-libs-xpcom18a4-Config.kmk.diff (1.4 KB) - added by ahmed@… 6 years ago.
patch-src-libs-xpcom18a4-python-gen_python_deps.py.diff (684 bytes) - added by ahmed@… 6 years ago.
patch-src-libs-xpcom18a4-python-Makefile.kmk.diff (452 bytes) - added by ahmed@… 6 years ago.
patch-build.diff.patch (475 bytes) - added by ahmed@… 6 years ago.

Download all attachments as: .zip

Change History (17)

Changed 6 years ago by ahmed@…

Portfile patch

Changed 6 years ago by ahmed@…

Changed 6 years ago by ahmed@…

comment:1 follow-up: Changed 6 years ago by ahmed@…

Correction: This patch INCLUDES my fixes in #31305

Guys, you should allow editing self-created tickets!

comment:2 in reply to: ↑ 1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Replying to ahmed@…:

Guys, you should allow editing self-created tickets!

If you can find out how to configure Trac to allow this, I imagine we'd be happy to do it.

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

  • Keywords haspatch added

comment:4 follow-up: Changed 6 years ago by royliu@…

What does the --disable-opengl flag do?

comment:5 in reply to: ↑ 4 ; follow-up: Changed 6 years ago by ahmed@…

Replying to royliu@…:

What does the --disable-opengl flag do?

Problem is that I couldn't build VirtualBox with opengl support because of the incompatibility between the OpenGL library in Lion with VirtualBox, somebody should be looking into that.

comment:6 Changed 6 years ago by royliu@…

  • Cc royliu@… added

Cc Me!

comment:7 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by royliu@…

Does it crash on startup, or only with the Python bindings? The rest of your change looks promising -- I'd just like to reproduce the OpenGL interaction.

Replying to ahmed@…:

Replying to royliu@…:

What does the --disable-opengl flag do?

Problem is that I couldn't build VirtualBox with opengl support because of the incompatibility between the OpenGL library in Lion with VirtualBox, somebody should be looking into that.

comment:8 Changed 6 years ago by royliu@…

  • Owner changed from macports-tickets@… to royliu@…

comment:9 in reply to: ↑ 7 ; follow-up: Changed 6 years ago by ahmed@…

Replying to royliu@…:

Does it crash on startup, or only with the Python bindings? The rest of your change looks promising -- I'd just like to reproduce the OpenGL interaction.

Replying to ahmed@…:

Replying to royliu@…:

What does the --disable-opengl flag do?

Problem is that I couldn't build VirtualBox with opengl support because of the incompatibility between the OpenGL library in Lion with VirtualBox, somebody should be looking into that.

No, compilation fails

comment:10 in reply to: ↑ 9 Changed 6 years ago by royliu@…

Is this problem Lion specific? Have you tried on Snow Leopard?

Replying to ahmed@…:

Replying to royliu@…:

Does it crash on startup, or only with the Python bindings? The rest of your change looks promising -- I'd just like to reproduce the OpenGL interaction.

Replying to ahmed@…:

Replying to royliu@…:

What does the --disable-opengl flag do?

Problem is that I couldn't build VirtualBox with opengl support because of the incompatibility between the OpenGL library in Lion with VirtualBox, somebody should be looking into that.

No, compilation fails

comment:11 Changed 6 years ago by royliu@…

Is the OpenGL issue orthogonal to that of Python bindings? I did not use the flag and VirtualBox builds fine on my machine. Did you install the OpenGL library and headers on top of the default Lion Xcode installation?

comment:12 Changed 6 years ago by royliu@…

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r84688. Please resubmit the OpenGL as a separate issue.

Note: See TracTickets for help on using tickets.