Opened 7 years ago

Closed 7 years ago

#31396 closed defect (invalid)

gnuplot cannot use x11 terminal

Reported by: raonath@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: derekathomas@…
Port:

Description

starting gnuplot and issuing "set terminal x11" fails with "unable to open display 'x11' X11 aborted". Even more baffling, DISPLAY environment variable is set (to 0.0) and TERM is set to xterm. This should set gnuplot plot to x11, but it is set to aqua.

I tried installing xorg package and restarting the computer. That did nothing, except that starting X11.app no longer starts a terminal by default. I have also tried uninstalling gnuplot and

its dependents and reinstalling, but nothing has changed.

Possibly related: "port list gnuplot" says gnuplot @4.4.3 math/gnuplot but the start-up message from gnuplot says version 4.2 patch level 5 last modified Mar 2009

Change History (4)

comment:1 Changed 7 years ago by raonath@…

I screwed up. Long ago, for reasons I can't remember, I had aliased gnuplot to a precomplied application. That kept being run, not Macports gnuplot (and of course, "which" does not look for such chicanery).

Everything works as it is supposed to (except that I need to do "set terminal x11" manually each time, while the man page seems to imply that I do not need to do that).

comment:2 Changed 7 years ago by derekathomas@…

Cc: derekathomas@… added

Cc Me!

comment:3 in reply to:  1 Changed 7 years ago by derekathomas@…

the gnu plot terminal is set through the GNUTERM environment variable. If you put "export GNUTERM=x11" in your shell's rc file, enjoy the the immediate x11 fun. Alternatively you can mess around with the $HOME/.gnuplot startup file to get the same results.

comment:4 Changed 7 years ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.