Opened 9 years ago

Closed 8 years ago

#31423 closed defect (worksforme)

py-wxpython: "class wxFont" has no member named "MacGetATSUFontID"

Reported by: pazerp@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-wxpython

Description (last modified by ryandesign (Ryan Schmidt))

Installed MacPorts about a week ago in order to install matplotlib. Matplotlib installed fine but I am now having problems with wxPython. Before matplotlib it worked fine, but now 'import wx' simply returns a 'no such module' error. Decided to try and reinstall it using MacPorts (first install was done 'manually'). Installs all dependencies okay but eventually fails with the following message:

--->  Building py-wxpython
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Status 1 encountered during processing.

Attachments (1)

main.log (58.9 KB) - added by pazerp@… 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by pazerp@…

Attachment: main.log added

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: py-wxpython removed
Owner: changed from macports-tickets@… to jwa@…
Summary: Failed install of py-wxpythonpy-wxpython: "class wxFont" has no member named "MacGetATSUFontID"

Do you really want the ancient python 2.4 version of wxpython? I suspect you want a newer python version. Try py27-wxpython or py26-wxpython.

comment:2 Changed 9 years ago by jmroot (Joshua Root)

Does this still happen with 2.8.12.1?

comment:3 Changed 8 years ago by mojca (Mojca Miklavec)

Resolution: worksforme
Status: newclosed
Version: 2.0.3

I'm unable to reproduce this with the new py24-wxpython-2.8 @2.8.12.1 +carbon. I'm closing the ticket. In case it is still an issue, please reopen the ticket and attach the new log. (Maybe the original error was related to a mismatch between wxPython and wxWidgets versions.)

Note: See TracTickets for help on using tickets.