Opened 8 years ago

Closed 8 years ago

#31467 closed defect (duplicate)

irssi 0.8.15 multiple arch build failure

Reported by: major@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: irssi

Description

I'm unable to build irssi 0.8.15 via MacPorts. Here is my system configuration:

Xcode 4.1

OS X 10.7.1

I get a stream of these before the build fails:

llvm-gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags
llvm-gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags
llvm-gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags
llvm-gcc-4.2: -E, -S, -save-temps and -M options are not allowed with multiple -arch flags

The full output will be attached to this ticket.

Attachments (1)

irssi-build-failure.txt (15.4 KB) - added by major@… 8 years ago.
irssi build failure

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by major@…

Attachment: irssi-build-failure.txt added

irssi build failure

comment:1 Changed 8 years ago by major@…

Cc: major@… added

Cc Me!

comment:2 Changed 8 years ago by major@…

I tried re-applying the fixes from r35400 and the build still fails.

comment:3 Changed 8 years ago by major@…

Just tried the workaround from comment four on #13004 and it build without a hitch!

sudo port -v clean irssi +perl
sudo port -v configure irssi +perl
cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_irc_irssi/irssi/work/
sudo find . -type f -exec sed -i "" -e "s/-arch i386//g" {} \;
cd
sudo port -v install irssi +perl

Does anyone know how to fix this permanently?

comment:4 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; major@… removed

I can't tell since you didn't attach the complete main.log file but it looks like a duplicate of #27212.

comment:5 Changed 8 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

No response; assuming duplicate of #24779.

Note: See TracTickets for help on using tickets.