Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#31848 closed defect (fixed)

apr libtool references gsed

Reported by: parzley@… Owned by: danielluke (Daniel J. Luke)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: apr

Description

Running OS/X 10.6.
The build failed; the log file mentioned that /opt/local/bin/gsed was not found; I installed gsed; the build worked.

Attachments (1)

main.log (35.0 KB) - added by parzley@… 7 years ago.
Log of failed build

Download all attachments as: .zip

Change History (13)

comment:1 Changed 7 years ago by danielluke (Daniel J. Luke)

This can probably be fixed the same way we fix apr (set something like ac_cv_path_SED=sed in configure.env).

comment:2 in reply to:  1 ; Changed 7 years ago by danielluke (Daniel J. Luke)

Replying to dluke@…:

This can probably be fixed the same way we fix apr (set something like ac_cv_path_SED=sed in configure.env).

I just quickly looked and I don't actually see 'gsed' in the configure script. It's even possible that it's coming from the apr port. A failed build log would probably be helpful.

Changed 7 years ago by parzley@…

Attachment: main.log added

Log of failed build

comment:3 in reply to:  2 Changed 7 years ago by parzley@…

Replying to dluke@…:

A failed build log would probably be helpful.

Consider it done.

comment:4 Changed 7 years ago by danielluke (Daniel J. Luke)

Owner: changed from macports-tickets@… to dluke@…
Port: apr added; serf1 removed
Status: newassigned
Summary: serf1 @1.0.0 +universal - Missing dependency on gsedapr libtool references gsed

comment:5 Changed 7 years ago by danielluke (Daniel J. Luke)

ok, the problem in your case is actually that the libtool that apr installs references used (and it shouldn't).

You have the current version of apr installed, which should be choosing 'sed' instead of 'gsed', so I'll need to figure out why that is happening.

comment:6 Changed 7 years ago by danielluke (Daniel J. Luke)

Looks like lt_cv_path_SED needs to be set as well (or perhaps SED can be set instead). Testing now, should have the port fixed soon.

comment:7 Changed 7 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: assignedclosed

Fixed in r86706

comment:8 Changed 7 years ago by parzley@…

I just tried testing the fix thus:

$ sudo port upgrade outdated
--->  Fetching archive for apr
--->  Attempting to fetch apr-1.4.5_2+universal.darwin_10.i386-x86_64.tbz2 from http://packages.macports.org/apr

<snip successful installation>

--->  Installing apr @1.4.5_2+universal

<snip>

$ sudo port uninstall gsed
--->  Deactivating gsed @4.2.1_2+universal
--->  Cleaning gsed
--->  Uninstalling gsed @4.2.1_2+universal
--->  Cleaning gsed
$ sudo port clean gsed
--->  Cleaning gsed
$ sudo port build serf1
--->  Computing dependencies for serf1
--->  Fetching serf1
--->  Verifying checksum(s) for serf1
--->  Extracting serf1
--->  Configuring serf1
--->  Building serf1
Error: Target org.macports.build returned: shell command failed (see log for details)
Log for serf1 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/main.log

... which produces the same error as before:

$ grep gsed /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/main.log | sort -u
:info:build /opt/local/share/apr-1/build/libtool: line 1100: /opt/local/bin/gsed: No such file or directory
:info:build /opt/local/share/apr-1/build/libtool: line 1153: /opt/local/bin/gsed: No such file or directory
:info:build /opt/local/share/apr-1/build/libtool: line 390: /opt/local/bin/gsed: No such file or directory
:info:build /opt/local/share/apr-1/build/libtool: line 789: /opt/local/bin/gsed: No such file or directory

Presumably, apr@1.4.5_2 is the new version, based on my reading of r86706? It seems to be the version used in the failed build of serf1:

$ grep ' apr ' /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_www_serf1/serf1/main.log
:debug:main apr 1.4.5_2 exists in the ports tree
:debug:main apr 1.4.5_2 +universal is the latest installed
:debug:main apr 1.4.5_2 +universal is active
:debug:main No need to upgrade! apr 1.4.5_2 >= apr 1.4.5_2

My knowledge of macports is not thorough - maybe my test is flawed? Otherwise, I'll leave you to reopen the ticket.

comment:9 Changed 7 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: closedreopened

can you attach the build log for apr?

If you want to regenerate it, do:

sudo port clean --all apr
sudo port -dv build apr

(you can run clean again after you've uploaded the build log).

Thanks.

comment:10 Changed 7 years ago by danielluke (Daniel J. Luke)

oh, I've just reproduced, it looks like this only happens with the universal variant.

comment:11 Changed 7 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: reopenedclosed

ok, this should be fixed now r86710

comment:12 Changed 7 years ago by parzley@…

apr @1.4.5, Revision 3 works for me. Thank you.

Note: See TracTickets for help on using tickets.