Opened 9 years ago

Closed 9 years ago

#31855 closed defect (worksforme)

lcms2: Checksums fails because an HTML file was downloaded

Reported by: ChuplesKai+devel@… Owned by: adfernandes (Andrew Fernandes)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: lcms2

Description

I've been trying to install lcms2, but the checksums are not validating. I looked through the FAQ, and I think the issue a stealth release. Looking at the maintainer's website, I was able to find the repository containing version 2.3 changes. The macports version reported is 2.2. I haven't had much luck messing with the checksums (I am fairly new to dealing with macports issues), so I'm kinda stuck.

I'm not sure if there is some easy way to work around this or if I'm simply going to have to wait for things to be fixed.

Attachments (1)

main.log (6.7 KB) - added by ChuplesKai+devel@… 9 years ago.
Macports logfile for installing lcms2.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by ChuplesKai+devel@…

Attachment: main.log added

Macports logfile for installing lcms2.

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to adfernandes@…
Summary: Checksums failing for lcms2lcms2: Checksums fails because an HTML file was downloaded

You didn't tell us where the bad file came from. Did you read MisbehavingServers? What does the bad file contain?

comment:2 Changed 9 years ago by ChuplesKai+devel@…

Ope, sorry, my bad... I got it from http://packages.macports.org/lcms and no, I hadn't seen that page. I apologize for my ignorance... I didn't see that little note there. It says that the mismatch file "appears to be HTML"... so I guess it could be something as small a documentation or something. I hope that's helpful.

comment:3 Changed 9 years ago by ChuplesKai+devel@…

After messing around with it for a little while, I discovered I had no problems of getting the lcms2 port installing as long as I don't use +universal. The +universal variant, however, seems to be problematic... and I've discovered no insights as to why.

comment:4 in reply to:  3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Replying to ChuplesKai+devel@…:

Ope, sorry, my bad... I got it from http://packages.macports.org/lcms

No; that's where our precompiled archives come from. That's not where distfiles come from.

It says that the mismatch file "appears to be HTML"... so I guess it could be something as small a documentation or something. I hope that's helpful.

It would be more helpful to see exactly what is in the file (/opt/local/var/macports/distfiles/lcms2/lcms2-2.2.tar.gz). Can you open it in a text editor and tell us what it says? Or attach it to this ticket?

Replying to ChuplesKai+devel@…:

After messing around with it for a little while, I discovered I had no problems of getting the lcms2 port installing as long as I don't use +universal. The +universal variant, however, seems to be problematic... and I've discovered no insights as to why.

That makes sense. When not using the universal variant, you're getting our precompiled binary from packages.macports.org. But we don't have precompiled binaries with universal variants yet, so when you request the universal variant, it can't find a package, and so it tries to compile it on your computer, by first downloading the distfile, with which it's having a problem.

comment:5 Changed 9 years ago by adfernandes (Andrew Fernandes)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.