Opened 7 years ago

Closed 6 years ago

#32035 closed defect (fixed)

wxWidgets-python - NotImplementedError: wx.GraphicsContext is not available on this platform.

Reported by: justjoheinz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: jameskyle@…, ryandesign (Ryan Schmidt), jyrkiwahlstedt, mojca (Mojca Miklavec)
Port: py26-wxpython wxWidgets-python

Description (last modified by ryandesign (Ryan Schmidt))

I am not sure which port exactly is causing the problem, the scenario is that I try to use a python programm which uses wxwdigets and I get the error:

NotImplementedError: wx.GraphicsContext is not available on this platform.

I found a bug report and a resolution for another program which can be seen here (nothing to do with macports): http://editra.org/forum/viewtopic.php?t=75

It seems that I need some variant of one of the many wxwidgets ports but I am not sure which one, or if it exists. I am happy to contribute more details if you send me the commands for the interesting debug information.

Change History (10)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… jwa@… added
Description: modified (diff)

The thread you reference says that a) graphics context should already be enabled and b) to force it to be enabled we could add --enable-graphics_ctx to the configure args. The latter is what was requested for wxWidgets-python in #31804 but it failed to build and we don't know how to make it succeed.

The above post also says the graphics context was not added until wxWidgets 2.8. Which wxWidgets port(s) are you using -- wxWidgets? wxWidgets26? wxgtk? wxWidgets-python?

comment:2 Changed 7 years ago by justjoheinz@…

How can I find out which port is used? Can you send me the relevant command?

comment:3 Changed 7 years ago by ryandesign (Ryan Schmidt)

You could look through the output of "port installed"

comment:4 Changed 7 years ago by justjoheinz@…

Thanks! wxWidgets-python @2.8.10.1_2+gtk seems to be the only one.

comment:5 Changed 7 years ago by jmroot (Joshua Root)

Port: wxWidgets-python added
Summary: wxwidgets - NotImplementedError: wx.GraphicsContext is not available on this platform.wxWidgets-python - NotImplementedError: wx.GraphicsContext is not available on this platform.

comment:6 Changed 7 years ago by jmroot (Joshua Root)

Cc: jameskyle@… added
Port: py26-wxpython added

So presumably also py26-wxpython since you're using it in python.

comment:7 Changed 6 years ago by mojca (Mojca Miklavec)

I just wanted to add that wxPython 2.9.4.0 seems to compile fine with --enable-graphics_ctx on 10.7, but I don't know how to test anything.

comment:8 Changed 6 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:9 Changed 6 years ago by mojca (Mojca Miklavec)

I also got it working with wxWidgets 2.8. See #31804.

comment:10 Changed 6 years ago by mojca (Mojca Miklavec)

Resolution: fixed
Status: newclosed
Version: 2.0.3

This should be fixed in r110234 and r110279. Please reopen in case it doesn't work.

Note: See TracTickets for help on using tickets.