Opened 7 years ago

Closed 7 years ago

#32122 closed defect (invalid)

xorg-libXext: error: must install xorg-macros 1.12 or later before running autoconf/autogen

Reported by: dwb@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: autoconf

Description (last modified by ryandesign (Ryan Schmidt))

[dwb-mbp:~] dwb% sudo port install xorg-libXext
--->  Computing dependencies for xorg-libXext
--->  Configuring xorg-libXext
Error: Target org.macports.configure returned: autoreconf failure: shell command failed (see log for details)
Log for xorg-libXext is at: /opt/local/var/macports/logs/_opt_macport_trunk_dports_x11_xorg-libXext/xorg-libXext/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
[dwb-mbp:~] dwb% 

Attachments (2)

main.log (39.6 KB) - added by dwb@… 7 years ago.
main.log
main.2.log (39.6 KB) - added by dwb@… 7 years ago.
main.log with minimal path

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by dwb@…

Attachment: main.log added

main.log

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to jeremyhu@…
Port: xorg-libXext added
Summary: "sudo port install xorg-libXext" fails on Lionxorg-libXext: error: must install xorg-macros 1.12 or later before running autoconf/autogen

comment:2 Changed 7 years ago by dwb@…

I'm pretty sure I have xorg-util-macros installed, and I've run self-update so I have the patches from 4 months ago.

[dwb-mbp:~] dwb% port installed xorg-util-macros
The following ports are currently installed:
  xorg-util-macros @1.15.0_0 (active)
[dwb-mbp:~] dwb% 

comment:3 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from jeremyhu@… to ram@…
Port: autoconf added; xorg-libXext removed

Are you setting ACLOCAL in your environment or in some other way messing up the search path? That looks like autoconf is using the macros from outside of MacPorts...

comment:4 Changed 7 years ago by dwb@…

Not that I know of.

ACLOCAL is not set in my environment.

I do have a lot of things in my PATH though, but resetting my path to a standard ( /usr/bin /bin /usr/sbin /sbin /usr/local/bin /opt/local/bin ) doesn't yield any different results.

comment:5 Changed 7 years ago by skymoo (Adam Mercer)

There must be something amiss with your setup as the system autotools are being used instead of the MacPorts versions:

:info:configure autom4te: /Developer/usr/bin/gm4 failed with exit status: 1
:info:configure aclocal: /Developer/usr/bin/autom4te failed with exit status: 1

hence it can't find the appropriate macros. Do you have autoconf and automake installed from MacPorts (they should be as the port specifies use_autoreconf)?

Changed 7 years ago by dwb@…

Attachment: main.2.log added

main.log with minimal path

comment:6 Changed 7 years ago by dwb@…

I still have the same error with a minimal path:

{

[dwb-mbp:~] dwb% sudo port installed autoconf automake Password: The following ports are currently installed:

autoconf @2.68_2 (active) automake @1.11.1_0 (active)

[dwb-mbp:~] dwb% set path = ( /usr/bin /bin /usr/sbin /opt/local/bin ) [dwb-mbp:~] dwb% sudo port install xorg-libXext ---> Computing dependencies for xorg-libXext ---> Configuring xorg-libXext Error: Target org.macports.configure returned: autoreconf failure: shell command failed (see log for details) Log for xorg-libXext is at: /opt/local/var/macports/logs/_opt_macport_trunk_dports_x11_xorg-libXext/xorg-libXext/main.log Error: Status 1 encountered during processing. To report a bug, see <http://guide.macports.org/#project.tickets> }

comment:7 Changed 7 years ago by skymoo (Adam Mercer)

I can't reproduce on either Lion (Xcode-4.2.1)

DEBUG: Using compiler 'Mac OS X clang'
DEBUG: Executing org.macports.configure (xorg-libXext)
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.7'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/libXext-1.3.0" && autoreconf --install -fvi'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/libXext-1.3.0" && autoreconf --install -fvi 
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force 
autoreconf: configure.ac: tracing
autoreconf: running: glibtoolize --copy --force
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
glibtoolize: rerunning glibtoolize, to keep the correct libtool macros in-tree.
glibtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
autoreconf: running: /opt/local/bin/autoconf --force
autoreconf: running: /opt/local/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'

nor Snow Leopard (Xcode-4.0.2)

DEBUG: Using compiler 'Mac OS X llvm-gcc 4.2'
DEBUG: Executing org.macports.configure (xorg-libXext)
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/libXext-1.3.0" && autoreconf --install -fvi'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_x11_xorg-libXext/xorg-libXext/work/libXext-1.3.0" && autoreconf --install -fvi 
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force 
autoreconf: configure.ac: tracing
autoreconf: running: glibtoolize --copy --force
glibtoolize: putting auxiliary files in `.'.
glibtoolize: copying file `./ltmain.sh'
glibtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
glibtoolize: rerunning glibtoolize, to keep the correct libtool macros in-tree.
glibtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
autoreconf: running: /opt/local/bin/autoconf --force
autoreconf: running: /opt/local/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'

What is binpath set to in ${prefix}/etc/macports/macports.conf?

comment:8 Changed 7 years ago by dwb@…

I'm using Xcode 4.2 atm, 4.2.1 is downloading still:

[dwb-mbp:~] dwb% fgrep binpath /opt/local/etc/macports/macports.conf
# paths are given in the example; it need not be uncommented.  Customizing binpath is intended for advanced users only.
binpath		/Developer/usr/bin:/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin
# while processing ports. As with binpath, setting extra_env is intended for
[dwb-mbp:~] dwb% 

comment:9 Changed 7 years ago by skymoo (Adam Mercer)

Thats the problem, by default this is commented out:

http://trac.macports.org/browser/trunk/base/doc/macports.conf.in#L15

You shouldn't need to modify this but you've added /Developer/usr/bin, why?

If you comment this out again I imagine that will fix the problem.

comment:10 Changed 7 years ago by dwb@…

I'm not sure why I would've changed it, but it would've been because port was looking for something and not finding it. In any case, commenting out the bin path line does seem to resolve the problems.

comment:11 Changed 7 years ago by skymoo (Adam Mercer)

Resolution: invalid
Status: newclosed

You should _never_ need to modify binpath, if something fails then file a ticket.

Note: See TracTickets for help on using tickets.