Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#32124 closed defect (fixed)

dsniff-devel @2.4b1_5 ld: symbol(s) not found for architecture x86_64

Reported by: nonstop.server@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: anonjoe@…
Port: dsniff-devel

Description

Port dsniff-devel @2.4b1_5 fails to build.

Undefined symbols for architecture x86_64:
  "_before", referenced from:
      _process_tcp in libnids.a(tcp.o)
      _add_from_skb in libnids.a(tcp.o)
  "_after", referenced from:
      _process_tcp in libnids.a(tcp.o)
      _add_from_skb in libnids.a(tcp.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [dsniff] Error 1

Version Information:

Mac OS Version:
Darwin 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug  9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64

Xcode Version:
Xcode 4.2
Build version 4D199

Macports Version:
Version: 2.0.3

Attachments (7)

macports_dsniff-devel_install.log (727.3 KB) - added by nonstop.server@… 7 years ago.
main.log (185.4 KB) - added by nonstop.server@… 7 years ago.
main_llvm-gcc-4.2.log (91.9 KB) - added by nonstop.server@… 7 years ago.
macports_dsniff-devel_llvm-gcc-4.2.log (90.9 KB) - added by nonstop.server@… 7 years ago.
main_apple-gcc-4.2.log (91.5 KB) - added by nonstop.server@… 7 years ago.
macports_dsniff-devel_apple-gcc-4.2.log (90.5 KB) - added by nonstop.server@… 7 years ago.
main.2.log (45.4 KB) - added by hrvxla@… 7 years ago.

Download all attachments as: .zip

Change History (19)

Changed 7 years ago by nonstop.server@…

Changed 7 years ago by nonstop.server@…

Attachment: main.log added

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: clang added; net removed

I see you're using clang. Does it work if you use llvm-gcc-4.2 instead?

comment:2 in reply to:  1 ; Changed 7 years ago by nonstop.server@…

Replying to ryandesign@…:

I see you're using clang. Does it work if you use llvm-gcc-4.2 instead?

Thank you very much for your advice to use llvm-gcc-4.2.
After cleaning the failed build the program compiled fine using llvm-gcc-4.2.

sudo port -d clean --all bwm-ng 2>&1 |tee -a macports_bwm-ng_clean.log

sudo port -d install bwm-ng configure.compiler=llvm-gcc-4.2 2>&1 |tee -a macports_bwm-ng_install.log

port installed name:bwm-ng
The following ports are currently installed:
  bwm-ng @0.6_0 (active)

comment:3 in reply to:  2 Changed 7 years ago by nonstop.server@…

Replying to nonstop.server@…:

Replying to ryandesign@…:

I see you're using clang. Does it work if you use llvm-gcc-4.2 instead?

Thank you very much for your advice to use llvm-gcc-4.2.
After cleaning the failed build the program compiled fine using llvm-gcc-4.2.

sudo port -d clean --all bwm-ng 2>&1 |tee -a macports_bwm-ng_clean.log

sudo port -d install bwm-ng configure.compiler=llvm-gcc-4.2 2>&1 |tee -a macports_bwm-ng_install.log

port installed name:bwm-ng
The following ports are currently installed:
  bwm-ng @0.6_0 (active)

Please disregard my reply, this was meant for ticket 32123, sorry for the mixup.

comment:4 in reply to:  1 Changed 7 years ago by nonstop.server@…

Replying to ryandesign@…:

I see you're using clang. Does it work if you use llvm-gcc-4.2 instead?

Unfortunately I was unable to build dsniff-devel using compiler llvm-gcc-4.2 or apple-gcc-4.2.
Please see the attached log files for their respective error messages.

  • llvm-gcc-4.2 files: main_llvm-gcc-4.2.log and macports_dsniff-devel_llvm-gcc-4.2.log
  • apple-gcc-4.2 files: main_apple-gcc-4.2.log and macports_dsniff-devel_apple-gcc-4.2.log

Changed 7 years ago by nonstop.server@…

Attachment: main_llvm-gcc-4.2.log added

Changed 7 years ago by nonstop.server@…

Changed 7 years ago by nonstop.server@…

Attachment: main_apple-gcc-4.2.log added

Changed 7 years ago by nonstop.server@…

comment:5 Changed 7 years ago by anonjoe@…

Don't you think the problem can caused by :

:info:archivefetch --->  dsniff-devel-2.4b1_5.darwin_11.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/software/dsniff-devel
:msg:archivefetch --->  Attempting to fetch dsniff-devel-2.4b1_5.darwin_11.x86_64.tbz2 from http://packages.macports.org/dsniff-devel
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404

?

comment:6 in reply to:  5 ; Changed 7 years ago by nonstop.server@…

Replying to anonjoe@…:

Don't you think the problem can caused by :

:info:archivefetch --->  dsniff-devel-2.4b1_5.darwin_11.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/software/dsniff-devel
:msg:archivefetch --->  Attempting to fetch dsniff-devel-2.4b1_5.darwin_11.x86_64.tbz2 from http://packages.macports.org/dsniff-devel
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404

?

The archive seems to have been downloaded, because it is present on my system.

$ ls -hl /opt/local/var/macports/distfiles/dsniff-devel/dsniff-2.4b1.tar.gz 
-rw-r--r--  1 macports  admin   129K Nov 19 13:10 /opt/local/var/macports/distfiles/dsniff-devel/dsniff-2.4b1.tar.gz

I can redo the whole exercise again with all three compilers and upload the new log files if you want.

comment:7 in reply to:  6 Changed 7 years ago by anonjoe@…

I can redo the whole exercise again with all three compilers and upload the new log files if you want.

I will not be necessary because I have exactly the problem.

When I try a

./configure

I've got this error :

checking for libnet... no
configure: error: libnet not found

but

sudo port installed libnet11
The following ports are currently installed:
  libnet11 @1.1.5_0 (active)

comment:8 Changed 7 years ago by anonjoe@…

Cc: anonjoe@… added

Cc Me!

Changed 7 years ago by hrvxla@…

Attachment: main.2.log added

comment:9 Changed 7 years ago by hrvxla@…

I'm seeing issues here, too.

$ sudo port install dsniff-devel ---> Computing dependencies for dsniff-devel ---> Building dsniff-devel Error: Target org.macports.build returned: shell command failed (see log for details) Log for dsniff-devel is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_dsniff-devel/dsniff-devel/main.log Error: Status 1 encountered during processing. To report a bug, see <http://guide.macports.org/#project.tickets>

--

$ uname -a Darwin iridium.local 11.2.0 Darwin Kernel Version 11.2.0: Tue Aug 9 20:54:00 PDT 2011; root:xnu-1699.24.8~1/RELEASE_X86_64 x86_64

comment:10 Changed 7 years ago by jmroot (Joshua Root)

Keywords: clang removed

I can't reproduce this.

comment:11 Changed 7 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Probably fixed by libnids being updated to 1.24; reopen if not.

comment:12 in reply to:  11 Changed 7 years ago by nonstop.server@…

Replying to jmr@…:

Yes, thank you for the information, I was now able to compile dsniff using llvm-gcc-4.2.

Note: See TracTickets for help on using tickets.