New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #32200 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Symbol not found: _modperl_handler_anon_add failing apache2 startup

Reported by: mauritz.lovgren@… Owned by: ryan@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: mod_perl2

Description (last modified by ryandesign@…) (diff)

I am getting the following error while starting port apache2 after having installed the following using latest MacPorts with updated ports tree:

install perl5 +threads (to make mod_perl2 compile)
install apache2
install mod_perl2

sudo /opt/local/apache2/bin/apachectl start

httpd: Syntax error on line 118 of /opt/local/apache2/conf/httpd.conf: Cannot load /opt/local/apache2/modules/mod_perl.so into server: dlopen(/opt/local/apache2/modules/mod_perl.so, 10): Symbol not found: _modperl_handler_anon_add\n  Referenced from: /opt/local/apache2/modules/mod_perl.so\n  Expected in: dynamic lookup\n

What might cause this and how can I get around it?

Change History

comment:1 Changed 2 years ago by ryandesign@…

  • Description modified (diff)

comment:2 in reply to: ↑ description Changed 2 years ago by r.thurnher@…

I'm getting this error similarly as well here.

Any news on this issue?

comment:3 follow-up: ↓ 4 Changed 2 years ago by software@…

I have the same issue.

mod_perl2 @2.0.4_0 (active) perl5 @5.12.3_1+perl5_12 (active) perl5.12 @5.12.3_3+threads (active)

comment:4 in reply to: ↑ 3 Changed 2 years ago by software@…

readable:

mod_perl2 @2.0.4_0 (active)
perl5 @5.12.3_1+perl5_12 (active)
perl5.12 @5.12.3_3+threads (active)

comment:5 Changed 2 years ago by jmr@…

  • Owner changed from macports-tickets@… to ryan@…

comment:6 Changed 2 years ago by cal@…

  • Status changed from new to closed
  • Resolution set to fixed

This is caused by the code assuming to be compiled using GCC against the GCC89 "standard", but being actually compiled by clang with C99. GNU89 and C99 differ in how they handle inline. Further reading: http://clang.llvm.org/compatibility.html#inline.

Fixed in r88512. Feel free to report upstream.

comment:7 Changed 2 years ago by merlyn.macports@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Nope, now it broke this way for me:

dhcp70.corp.mediatemple.net:~ % sudo port uninstall mod_perl2
--->  Deactivating mod_perl2 @2.0.4_0
--->  Cleaning mod_perl2
--->  Uninstalling mod_perl2 @2.0.4_0
--->  Cleaning mod_perl2

dhcp70.corp.mediatemple.net:~ % sudo port clean --all mod_perl2                   
dhcp70.corp.mediatemple.net:~ % sudo port -spuv install mod_perl2
--->  Computing dependencies for mod_perl2.
--->  Fetching mod_perl2
--->  mod_perl-2.0.4.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/mod_perl2
--->  Attempting to fetch mod_perl-2.0.4.tar.gz from http://distfiles.macports.org/mod_perl2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 3640k  100 3640k    0     0   833k      0  0:00:04  0:00:04 --:--:--  866k
--->  Verifying checksum(s) for mod_perl2
--->  Checksumming mod_perl-2.0.4.tar.gz
--->  Extracting mod_perl2
--->  Extracting mod_perl-2.0.4.tar.gz
--->  Applying patches to mod_perl2
--->  Applying /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/www/mod_perl2/files/clang-compatibility_src-modules-perl-modperl_common_util.h.patch
patching file src/modules/perl/modperl_common_util.h
--->  Configuring mod_perl2
Error: Target org.macports.configure returned: invalid bareword "define"
in expression "!define";
should be "$define" or "{define}" or "define(...)" or ...
Warning: the following items did not execute (for mod_perl2): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
Log for mod_perl2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_mod_perl2/mod_perl2/main.log
Error: Status 1 encountered during processing.

comment:8 Changed 2 years ago by cal@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Sorry, should be fixed in r88513.

Note: See TracTickets for help on using tickets.