Opened 9 years ago

Closed 9 years ago

#32296 closed defect (invalid)

Missing p5.12-xxx ports

Reported by: carcode@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port:

Description (last modified by neverpanic (Clemens Lang))

I am doing an upgrade and found several items missing in the index:

- p5.12-xml-parser
- p5.12-getopt-long
- p5.12-pathtools
- p5.12-scalar-list-utils
- p5.12-locale-gettext

All missing port names starts with p5.12!!! What is wrong here with MacPorts?

Change History (6)

comment:1 Changed 9 years ago by neverpanic (Clemens Lang)

Description: modified (diff)
Port: p5 removed
Priority: HighNormal

High priority is reserved for MacPorts developers as stated in the Ticket Guidelines. Also, please remember to use WikiFormatting.

Please provide the exact output of port that makes you think those ports are not in the index. Please also make sure you're running the latest MacPorts version by running port selfupdate. You may have to run selfupdate up to two times.

comment:2 Changed 9 years ago by carcode@…

Thank you for that stupid answer. I am running selfupdate not only twice but the whole day already. I see in other tickets that I am not the only one with that faults!!! Please change this ticket back to HIGH priority!

comment:3 Changed 9 years ago by neverpanic (Clemens Lang)

Thank you for your polite answer. I can't reproduce your problem:

$ port info p5.12-xml-parser p5.12-getopt-long p5.12-pathtools p5.12-scalar-list-utils p5.12-locale-gettext
p5.12-xml-parser @2.400.0, Revision 2 (perl, textproc)
Sub-ports:            p5.8-xml-parser, p5.10-xml-parser, p5.12-xml-parser, p5.14-xml-parser
Variants:             universal

Description:          This is a Perl extension interface to James Clark's XML parser, expat.
Homepage:             http://search.cpan.org/dist/XML-Parser/

Library Dependencies: perl5.12, expat
Platforms:            darwin
License:              Artistic GPL
Maintainers:          mjg@phoenixtrap.com
--
p5.12-getopt-long @2.380.0, Revision 2 (perl, devel)
Sub-ports:            p5.8-getopt-long, p5.10-getopt-long, p5.12-getopt-long, p5.14-getopt-long

Description:          Module Getopt::Long implements an extended getopt function called GetOptions(). This function implements the POSIX standard for command line options, with GNU extensions, while still
                      capable of handling the traditional one-letter options. In general, this means that command line options can have long names instead of single letters, and are introduced with a double
                      dash `--'.
Homepage:             http://search.cpan.org/dist/Getopt-Long/

Library Dependencies: perl5.12
Platforms:            darwin
License:              Artistic GPL-2+
Maintainers:          nomaintainer@macports.org
--
p5.12-pathtools @3.330.0, Revision 2 (perl)
Sub-ports:            p5.8-pathtools, p5.10-pathtools, p5.12-pathtools, p5.14-pathtools
Variants:             universal

Description:          PathTools contains path building and modification classes.
Homepage:             http://search.cpan.org/dist/PathTools/

Library Dependencies: perl5.12
Platforms:            darwin
License:              GPL Artistic
Maintainers:          dluke@geeklair.net, openmaintainer@macports.org
--
p5.12-scalar-list-utils @1.230.0, Revision 2 (perl)
Sub-ports:            p5.8-scalar-list-utils, p5.10-scalar-list-utils, p5.12-scalar-list-utils, p5.14-scalar-list-utils
Variants:             universal

Description:          Perl subroutines that would be nice to have in the perl core
Homepage:             http://search.cpan.org/dist/Scalar-List-Utils/

Library Dependencies: perl5.12
Platforms:            darwin
License:              Artistic GPL
Maintainers:          nomaintainer@macports.org
--
p5.12-locale-gettext @1.50.0, Revision 6 (perl)
Sub-ports:            p5.8-locale-gettext, p5.10-locale-gettext, p5.12-locale-gettext, p5.14-locale-gettext
Variants:             universal

Description:          Perl interface to GNU gettext
Homepage:             http://search.cpan.org/dist/gettext/

Library Dependencies: perl5.12, gettext, libiconv
Platforms:            darwin
License:              Artistic GPL
Maintainers:          l2g@macports.org, openmaintainer@macports.org

The most common cause for a problem like this is not having a recent MacPorts version, because the p5.12-* ports are not real ports but only generated from their corresponding p5-* ports. Others having this problem have previously resolved these problems by running selfupdate, because this feature is only contained in newer MacPorts versions. So sorry for suggesting to run selfupdate, I should have known you already did this, because you mentioned it in your first post.

I also checked the rsync download and the ports in question are contained in the tarball and error-free.

Please provide the requested output as well as the output of port version. I will not change the priority back to high, but rest assured that the priority does not make a difference at all at the moment.

comment:4 Changed 9 years ago by ryandesign (Ryan Schmidt)

Messages about missing p5.*- ports are almost always caused by having MacPorts 1.x, running selfupdate once to upgrade to MacPorts 2.x, and the index not being rebuilt properly. The solution to that is to run selfupdate a second time, which rebuilds the index properly. If that's not solving the problem in your case, then we'd like to see the error messages you're seeing, and also the output of "sudo port -v selfupdate".

comment:5 Changed 9 years ago by carcode@…

Thank you for repairing your database index. The p5 files are now available and the upgrade works. As my logfiles shows there have been several typos in the version numbering of you database, e.g. 1.50 instead of 1.05 or 2.380.0_0 instead of 2.38_0 and so on for these files.

comment:6 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: invalid
Status: newclosed

We have not repaired our database index, in fact, we don't even have the database index, because the index is generated by the client. We only have the Portfiles, and those have not been changed.

What seem to be typos in the version numbers are actually appended zeroes to convert the version number to a different format. E.g. if you look at the contents of port file p5-locale-gettext it will tell you the correct (CPAN) version number 1.05, which is converted to 1.50 by the perl5 portgroup (source:trunk/dports/_resources/port1.0/group/perl5-1.0.tcl, proc perl5_convert_version). The same applies to p5-getopt-long. Typos in those Portfiles would be uncommon, because a large part of this info is automatically generated from CPAN by a script: source:contrib/cpan2port/cpan2port.

As the problem has apparently been resolved, I'm closing this ticket. Feel free to re-open if you deem the problem unfixed.

Note: See TracTickets for help on using tickets.