Opened 9 years ago

Closed 9 years ago

#32362 closed defect (duplicate)

bzip2-1.0.6 install fails

Reported by: bonomo@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: bzip2

Description (last modified by ryandesign (Ryan Schmidt))

Screen output:

iecbook:~ iec$ sudo port clean bzip2
Password:
--->  Cleaning bzip2
iecbook:~ iec$ sudo port -d install bzip2
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/archivers/bzip2
DEBUG: OS darwin/8.11.0 (Mac OS X 10.4) arch powerpc
DEBUG: org.macports.load registered provides 'load', a pre-existing procedure. Target override will not be provided
DEBUG: org.macports.distfiles registered provides 'distfiles', a pre-existing procedure. Target override will not be provided
DEBUG: Reading variant descriptions from /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/_resources/port1.0/variant_descriptions.conf
DEBUG: universal variant already exists, so not adding the default one
DEBUG: Attempting ln -sf /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/work /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/archivers/bzip2/work
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 500
DEBUG: euid changed to: 502
DEBUG: Starting logging for bzip2
DEBUG: Executing org.macports.main (bzip2)
DEBUG: changing euid/egid - current euid: 0 - current egid: 0
DEBUG: egid changed to: 500
DEBUG: euid changed to: 502
DEBUG: archivefetch phase started at Thu Dec  1 21:40:04 CST 2011
--->  Fetching archive for bzip2
DEBUG: Executing org.macports.archivefetch (bzip2)
DEBUG: euid/egid changed to: 0/0
DEBUG: chowned /opt/local/var/macports/software/bzip2 to macports
DEBUG: euid/egid changed to: 502/500
DEBUG: euid/egid changed to: 0/0
DEBUG: chowned /opt/local/var/macports/incoming to macports
DEBUG: euid/egid changed to: 502/500
--->  bzip2-1.0.6_0.darwin_8.ppc.tbz2 doesn't seem to exist in /opt/local/var/macports/software/bzip2
--->  Attempting to fetch bzip2-1.0.6_0.darwin_8.ppc.tbz2 from http://packages.macports.org/bzip2
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:08 --:--:--     0
DEBUG: Fetching archive failed:: The requested URL returned error: 404
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: fetch phase started at Thu Dec  1 21:40:13 CST 2011
--->  Fetching bzip2
DEBUG: euid/egid changed to: 0/0
DEBUG: chowned /opt/local/var/macports/distfiles/bzip2 to macports
DEBUG: euid/egid changed to: 502/500
DEBUG: Executing org.macports.fetch (bzip2)
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: checksum phase started at Thu Dec  1 21:40:13 CST 2011
--->  Verifying checksum(s) for bzip2
DEBUG: Executing org.macports.checksum (bzip2)
--->  Checksumming bzip2-1.0.6.tar.gz
DEBUG: Correct (md5) checksum for bzip2-1.0.6.tar.gz
DEBUG: Correct (sha1) checksum for bzip2-1.0.6.tar.gz
DEBUG: Correct (rmd160) checksum for bzip2-1.0.6.tar.gz
DEBUG: Privilege de-escalation not attempted as not running as root.
DEBUG: extract phase started at Thu Dec  1 21:40:14 CST 2011
--->  Extracting bzip2
DEBUG: Executing org.macports.extract (bzip2)
--->  Extracting bzip2-1.0.6.tar.gz
DEBUG: setting option extract.args to '/opt/local/var/macports/distfiles/bzip2/bzip2-1.0.6.tar.gz'
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.4'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/bzip2/bzip2-1.0.6.tar.gz' | /usr/bin/gnutar --no-same-owner -xf -'
DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/bzip2/bzip2-1.0.6.tar.gz' | /usr/bin/gnutar --no-same-owner -xf - 
/usr/bin/gnutar: unrecognized option `--no-same-owner'
Try `/usr/bin/gnutar --help' for more information.

gzip: stdout: Broken pipe
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/bzip2/bzip2-1.0.6.tar.gz' | /usr/bin/gnutar --no-same-owner -xf - " returned error 2
Error: Target org.macports.extract returned: shell command failed (see log for details)
DEBUG: Backtrace: shell command failed (see log for details)
    while executing
"$procedure $targetname"
Warning: the following items did not execute (for bzip2): org.macports.activate org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Log for bzip2 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_archivers_bzip2/bzip2/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
iecbook:~ iec$ 

Attachments (1)

main.log (4.2 KB) - added by bonomo@… 9 years ago.
installation log file

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by bonomo@…

Attachment: main.log added

installation log file

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Description: modified (diff)
Keywords: broken pipe shell command error2 removed
Owner: changed from macports-tickets@… to ryandesign@…

Remember to use WikiFormatting.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

It looks like your /usr/bin/gnutar command is broken. Possibly, somehow it has been replaced by an older version. What does "/usr/bin/gnutar --version" say? What does "ls -l /usr/bin/gnutar" say?

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Looks like a duplicate of #7373.

comment:4 Changed 9 years ago by bonomo@…

What does "/usr/bin/gnutar --version" say?

tar (GNU tar) 1.13

(followed by Copyright information)

What does "ls -l /usr/bin/gnutar" say?

-rwxr-xr-x    1 root wheel 153244 Jul 27  2002  /usr/bin/gnutar

(note: I may be unable to respond promptly to queries for the next day or two)

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Great, that confirms this is a duplicate of #7373, that you have somehow replaced /usr/bin/gnutar with a version older than the one that should be on Tiger (1.14), that this old version is incompatible with MacPorts, and that you should restore a compatible version from your backups or from your OS X install DVD (comment:ticket:7373:4 has advice for the latter, should you need it).

Note: See TracTickets for help on using tickets.