Opened 9 years ago

Closed 8 years ago

#32377 closed defect (fixed)

ccrypt @1.9 tests fail when built with clang

Reported by: mnagy@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), ryandesign (Ryan Schmidt)
Port: ccrypt

Description

Installing ccrypt-1.9 fails in the test execution stage (package's own regression test fails).

Attaching log.

Attachments (2)

main.log (12.0 KB) - added by mnagy@… 9 years ago.
log file
main.2.log (38.0 KB) - added by mnagy@… 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by mnagy@…

Attachment: main.log added

log file

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: ccrypt removed
Milestone: MacPorts 2.0.4

Please clean and try again and attach the full main.log. Then, try using an alternate compiler to see if that fixes it; let us know.

Note that the Milestone field is not used for port tickets, and that there's no need to repeat the port name in the Keywords field.

comment:2 Changed 9 years ago by mnagy@…

Thanks for the prompt answer!

Cleaning and installing failed again, attaching full log.

Changed 9 years ago by mnagy@…

Attachment: main.2.log added

comment:3 Changed 9 years ago by mnagy@…

As suggested in the alternate compiler section, installing with configure.compiler=llvm-gcc-4.2 does work. Thanks!

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Cc: jeremyhu@… added

Well this is a fun one. I tried adding -Wall -Wextra -fcatch-undefined-behavior to configure.cflags to see if it turned up anything, and it turns out that using -fcatch-undefined-behavior makes the test suite pass.

Versions:

% clang -v
Apple clang version 3.1 (tags/Apple/clang-318.0.61) (based on LLVM 3.1svn)
Target: x86_64-apple-darwin11.4.0
Thread model: posix
% xcodebuild -version
Xcode 4.3.3
Build version 4E3002

I've blacklisted clang for this port in r94768, until we can figure out the real problem.

comment:5 Changed 8 years ago by jmroot (Joshua Root)

Summary: ccrypt-1.9 install failsccrypt @1.9 tests fail when built with clang

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed

Verified with:

$ clang -v
Apple clang version 3.1 (tags/Apple/clang-318.0.61) (based on LLVM 3.1svn)
Target: x86_64-apple-darwin11.4.2
Thread model: posix

But unable to reproduce with:

$ clang -v
Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)
Target: x86_64-apple-darwin12.2.1
Thread model: posix

Changing port to only blacklist clang 318.0.61 and older in r102057. That should be enough to be able to close this ticket, though possibly we'll need to adjust that version number if we learn of other newer versions of clang also affected.

Note: See TracTickets for help on using tickets.