Opened 9 years ago

Closed 9 years ago

#32659 closed defect (invalid)

glib2 build fails when system python has been replaced with python 3

Reported by: thewickedfreak@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: glib2

Description

When I try to install ffmpeg, glib2 fails to install with the following message:

Error: Status 1 encountered during processing.

I use OS 10.7.2 and I also tried to separately build glib2 being prompted with the same error.

Attachments (2)

main.log (19.8 KB) - added by thewickedfreak@… 9 years ago.
main.2.log (703.1 KB) - added by thewickedfreak@… 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by thewickedfreak@…

Attachment: main.log added

comment:1 Changed 9 years ago by thewickedfreak@…

Cc: thewickedfreak@… added

Cc Me!

comment:2 Changed 9 years ago by neverpanic (Clemens Lang)

Cc: thewickedfreak@… removed
Keywords: ffmpeg glib2 removed
Milestone: MacPorts 2.0.4
Owner: changed from macports-tickets@… to ryandesign@…
Port: glib2 added; ffmpeg removed

You don't need to Cc yourself. Please don't set the milestone field. Please remember to Cc the maintainer.

What does /usr/bin/python --version print? Which Xcode version do you have?

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Summary: ffmpeg fails to install glib2glib2 build fails

This was not a clean build attempt; please "sudo port clean glib2" and try again and attach the new main.log.

Changed 9 years ago by thewickedfreak@…

Attachment: main.2.log added

comment:4 Changed 9 years ago by thewickedfreak@…

python 3.2.2 Xcode 4.2.1

Cleaning glib2 did not help.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: invalid
Status: newclosed
Summary: glib2 build failsglib2 build fails when system python has been replaced with python 3

How / why did you replace Mac OS X's python with version 3.2.2? That's bound to cause all sorts of problems, and not just with the glib2 port. Please put OS X's version of python back.

Note: See TracTickets for help on using tickets.