Opened 9 years ago

Closed 9 years ago

#32713 closed defect (fixed)

qgis @1.7.0_0 +python31 build failure

Reported by: larryv (Lawrence Velázquez) Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc:
Port: qgis

Description

Attempting to install qgis @1.7.0_0 with the +python31 variant fails during the build phase. It builds successfully with +python27.

Mac OS X 10.7.2 (11C74), Xcode 4.2.1 (4D502), MacPorts 2.0.3.

Attachments (1)

main.log.bz2 (19.8 KB) - added by larryv (Lawrence Velázquez) 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by larryv (Lawrence Velázquez)

Attachment: main.log.bz2 added

comment:1 Changed 9 years ago by mf2k (Frank Schima)

Cc: vince@… removed
Owner: changed from macports-tickets@… to vince@…

comment:2 Changed 9 years ago by Veence (Vincent)

Status: newassigned

I am going to have a look at this, though I am unsure that Qgis supports Python 3000. I must also bump to 1.7.2, by the way.

comment:3 Changed 9 years ago by Veence (Vincent)

Well, I am almost able to post a new Portfile for 1.7.4. Hold a few minutes!

comment:4 Changed 9 years ago by Veence (Vincent)

Done. Please try again.

comment:5 Changed 9 years ago by Veence (Vincent)

Resolution: fixed
Status: assignedclosed

After asking QGis development team, it appears QGis is not yet compatible with Python 3. I’ve thus removed the variant.

Note: See TracTickets for help on using tickets.