Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32811 closed defect (duplicate)

cairo @1.10.2_4+no_x11 fails building when /usr/bin/gcc-4.2 is present with Xcode 4.2

Reported by: jerkejacobs@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: haspatch Cc: raimue (Rainer Müller), robin@…
Port: cairo

Description

Dear all,

I tried installing doxygen +no_x11 and it got stuck on the cairo dependency.

Attachments (2)

main.log (49.6 KB) - added by jerkejacobs@… 9 years ago.
Build log
cairo-llvm-gcc-disable-lto.diff (1.2 KB) - added by raimue (Rainer Müller) 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by jerkejacobs@…

Attachment: main.log added

Build log

comment:1 Changed 9 years ago by raimue (Rainer Müller)

Cc: ryandesign@… removed
Keywords: cairo removed
Owner: changed from macports-tickets@… to ryandesign@…
Summary: Cairo 1.10.2 fails buildingcairo @1.10.2_4+no_x11 fails building

Looks similar to #32087.

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

What version of Xcode do you have? #32087 was about users who had Xcode >= 4.2, yet somehow also had /usr/bin/gcc-4.2.

comment:3 Changed 9 years ago by raimue (Rainer Müller)

When upgrading from Xcode <4.2 the App Store installer does not remove old files. Thus, /usr/bin/gcc-4.2 will exist for many users. We cannot tell which older version of Xcode was installed before the update. The Xcode installer from the App Store does not populate the receipt database (which would have been useful for stuff like pkg-util --file-info). This file might as well be from an ancient version such as Xcode 3.x -- imagine a user just upgrading from Snow Leopard.

The reason to disable both llvm-gcc-4.2 and clang in cairo was #31469, where build problems were encountered. I was able to build cairo using clang (although port test fails, but so does it with gcc-4.2). Building with llvm-gcc-4.2 would probably work when removing -flto from the LDFLAGS with a patch for the configure script or in post-configure with a reinplace for the Makefile.

$ xcodebuild -version
Xcode 4.2.1
Build version 4D502

comment:4 Changed 9 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Cc Me!

Changed 9 years ago by raimue (Rainer Müller)

comment:5 Changed 9 years ago by raimue (Rainer Müller)

Here is a patch to the cairo port adding an additional patch for the configure script to disable lto when building using llvm-gcc-4.2.

(Sorry, I realize I somehow high-jacked this ticket. But I believe the problem reported here is caused by using an ancient /usr/bin/gcc-4.2.)

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Keywords: haspatch added
Resolution: duplicate
Status: newclosed
Summary: cairo @1.10.2_4+no_x11 fails buildingcairo @1.10.2_4+no_x11 fails building when /usr/bin/gcc-4.2 is present with Xcode 4.2

Duplicate of #32087.

comment:7 Changed 9 years ago by robin@…

Cc: robin@… added

Cc Me!

Note: See TracTickets for help on using tickets.