Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#32966 closed defect (fixed)

py25-webhelpers not found while cleaning

Reported by: gary.verhaegen@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: ollie@…, J.Liem@…, lperry (Perry Lee), s.brown549@…
Port: py25-webhelpers

Description

Macports 2.0.3, just did a selfupdate. Doing a port clean all crashes at py25-webhelpers. Reproducing with limited scope :

$ sudo port clean py25-w*
--->  Cleaning py25-weberror
Error: Unable to open port: Port extract failed: tar: Error opening archive: Failed to open '/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/python/py25-WebHelpers'

And when I look for the above-mentioned folder on the filesystem, it simply does not exist :

$ ls /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/python/ | grep -i help
py-webhelpers

Change History (11)

comment:1 Changed 9 years ago by ollie@…

Cc: ollie@… added

Cc Me!

comment:2 Changed 9 years ago by ollie@…

For what it's worth,

port clean py25-weberror

worked just fine for me. (OSX 10.5.8)

comment:3 Changed 9 years ago by J.Liem@…

Cc: J.Liem@… added

Cc Me!

comment:4 in reply to:  2 Changed 9 years ago by gary.verhaegen@…

Replying to ollie@…:

For what it's worth,

port clean py25-weberror

worked just fine for me. (OSX 10.5.8)

That command works fine here too; the problem is with the py25-webhelpers port. I just did a selfupdate and the problem seem to persist. It even happens on a clean install with no port installed.

comment:5 Changed 9 years ago by mac.ports.fishspit@…

I ran into this as well, I suspect r89155 has something to do with it.

comment:6 Changed 9 years ago by s.brown549@…

FWIW I get this too (OSX 10.6.8).

Interestingly though...

 sudo port clean py25-weberror

doesn't report any error but I then get the error again while doing

 sudo port clean all

If possible, please cc me on any fix for this.

comment:7 Changed 9 years ago by mf2k (Frank Schima)

@s.brown549: You can Cc yourself on any ticket by pressing the "CcMe!" button.

comment:8 Changed 9 years ago by drkp (Dan Ports)

Owner: changed from macports-tickets@… to dports@…
Status: newassigned

comment:9 Changed 9 years ago by drkp (Dan Ports)

Cc: perry@… added
Resolution: fixed
Status: assignedclosed

Yes, this happens after a duplicate port has been removed.

I made a no-op change to the py-webhelpers in r89452 to force it to be reindexed. Should work fine after a port selfupdate

comment:10 Changed 9 years ago by drkp (Dan Ports)

Same problem with py26-robotframework-seleniumlibrary; fixed in r89453

comment:11 Changed 9 years ago by s.brown549@…

Cc: s.brown549@… added

Cc Me!

Note: See TracTickets for help on using tickets.